Philips 963sa progreesive scan problem

Discussion in 'Blu-ray & DVD Players & Recorders' started by Jules12, Jun 7, 2004.

  1. Jules12

    Jules12
    Active Member

    Joined:
    Oct 29, 2001
    Messages:
    271
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Frinton on Sea
    Ratings:
    +10
    I have had this dvd player for some time now and have only just purchased a plasma to see the full benefit of progressive scan. However it now seems that my player has this problem with the green vertical banding on the left hand side of the screen during playback in PScan mode. I have just phoned Philips and they deny any knowledge of known issues with this machine. Can someone who has had theirs repaired please explain what they did or anyone's name at Philips that knows about the fix.
     
  2. Klippie

    Klippie
    Member

    Joined:
    Dec 1, 2002
    Messages:
    689
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    46
    Location:
    Scotland
    Ratings:
    +100
    Jules,

    I had my 963sa repaired by Philips some time ago, it was still under warranty at the time though. All I did was take it back to the shop I bought it from with a written explanation of the faults they sent it off to Philips service center, it came back a few weeks later fixed.

    I would get back on the blower to Philips and don’t give up as there is a fix for the banding problem….good luck.

    Klippie.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice