Philips 42PF7

Discussion in 'Philips TVs Forum' started by 65jona, Jan 25, 2008.

  1. 65jona

    65jona
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have a philips 42 inch plasma which I have had for two years and is working great. I have just purchased a Harmen Kardon Amp with HDMI input output on the back. My TV is connected via HD DVi with sound through the amp. I also have a PS3 connected through HDMI. My problem is when using DVD or PS3 for play back I get horizontal lines of green spots during dark shots. I have taken the AV Receiver back to the store and they have swapped it but that didnt work. I have swapped my leads and that doesnt work. can ayone please shed any light on this as while the sound is fantastic its reall spoiling the picture
     
  2. UKseless1

    UKseless1
    Active Member

    Joined:
    Mar 9, 2005
    Messages:
    842
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Ratings:
    +36
    Tried plugging directly into the the TV as part of your problem determination?
     
  3. 65jona

    65jona
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks. I have just tried this plus commected the sound by coaxial and it works perfect. Must be an amp issue so I'll go to Harmen Direct.
     
  4. 65jona

    65jona
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Tried top quality leads and shop tested amp, all working well. Shop says may need a seperate HDMI spliter which has a booster on it. Thibks it may be TV??
     

Share This Page

Loading...