1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Philips 32PW9618:- Permanent sound problem since VCD 2.0 playback. Sound now tinny..!

Discussion in 'Televisions' started by WiCkEd SwInE, Jul 19, 2004.

  1. WiCkEd SwInE

    WiCkEd SwInE
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hope someone can help as with this:

    I have a Philips 32PW9618 TV and since last week the overall sound of the unit has changed permanently after playing a VCD 2.0 disc through a Philips DVD 625 player connected via a 3 way scart splitter in RGB socket 2.

    The change of the sound is hard to describe but the best way to explain would be that its become much more “tinny” with a lot more “echo” and just immediately noticeable from what it once was. When sound is being followed across the screen it dips in-and-out in a very unusual sort of way, kind of cutting out briefly before returning to its tinny state.

    The problem has nothing to do with the actual TV settings: Equalizer, Volume, Balance, Centre Volume, etc.

    I noticed that whenever I changed the volume of the TV via the normal remote ( whilst using the above combination, NTSC VCD 2.0, Scart Splitter, Philips 625, etc) there would be a ‘muffled clicking’ (duff, …. duff, …. duff) noise in the background during each increase in volume.. this clicking noise now seems to possibly be the time when the internal sound-settings changed from their usual state.

    I also noted at the time of playback that there was very low volume sound feedback (couldn’t understand why) from the terrestrial aerial being played through the side speakers, noticeable during quieter moments in the VCD

    I wonder what my best method would be to fix the problem seeing as its very unusual. I would presume that I would be best making contact with a Philips technical department,. in which case can anyone provide me with any email and contact numbers that might be of use?


    Thanks, ..
     
  2. torkelom

    torkelom
    Standard Member

    Joined:
    Jul 15, 2004
    Messages:
    39
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Location:
    Norway
    Ratings:
    +0
    Hi

    I would reset the tv to factory settings. You will find this option under installastion menu.
    Also try to turn of "Auto surround" and other virtuell surround sound..
     
  3. WiCkEd SwInE

    WiCkEd SwInE
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    This has already been done, resetting the unit to factory defaults, etc. The problem remains and is almost certainly internal and out of my control.

    As I said in the original post - there was a dull "thumping" sound each time the volume was increased during playback of the NTSC VCD2.0; somehow the combination of the sound from this through scart has caused the unit screw up its internal sound system..
     
  4. torkelom

    torkelom
    Standard Member

    Joined:
    Jul 15, 2004
    Messages:
    39
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Location:
    Norway
    Ratings:
    +0
    In that case, I would contact a philips service station, and see what they suggested.
     
  5. WiCkEd SwInE

    WiCkEd SwInE
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I'll email the problem via the technical support at the official Philips website and await a response.

    * If anyone knows of any better higher-up email addresses at Philips or telephone numbers then please list them as I really need to resolve this problem.
     

Share This Page

Loading...