PCH - not seeing my flash drive

wilno

Standard Member
Hi

Just got it, but cannot get it to see the 16GB corsair FD I plug in the front. Have updated today to the latest version via the internet. Have tried just avi's on the flash as well as .264 stuff but it will only find networked stuff?

Must be doing something wrong - the usb drive does not indicate it's being read at all when I plug it in. It's formatted NTFS and have tried both usb sockets.

Anyone??

Thanks
 

chris57

Novice Member
Corsair USB drives are problematic due to their power requirements. There were problems with the Phillips 5960 usb and some corsair adapters. Does it have any supplier software such as U3 still on it?

try formatting it again with Paragon or similar. Hopefully it should show any hidden partitions etc.
 

wilno

Standard Member
Thanks Chris

I didn't mention I was using a spare power cord (UK plug) with a 3 amp fuse in it. Your mention of power requirements made me try a 5 amp fuse and bingo - it can see the flash.

Cheers
 

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom