PC wont see XD card from Olympus camera

hig

Standard Member
I had an Olympus FE170 for xmas off the missus to replace my old 2mp camera. She also bought a 512mb FUJI XD H picture card.
I formatted the card in the camera and used it over xmas to take 100 or so shots.
I can view them all fine on the camera.

I took it out today and inserted into my all-in-one card reader which has a slot marked XD, but it says it cannot read the card and it might be corrupted and asks if I want to format it. It opens the H drive to the Olympus folder but wont then open the subfolder containing the images.

When I put it back into the camera again I can view all photos so as far as I can tell the card is ok.
Can anyone help me get the photos off the card??
They are mainly of my 11month olds first xmas and we really dont want to lose them....

I have tried connecting camera direct via usb, but the Olympus software bundled with the camera says no device detected, even though its showing as a mass storage device in device manager..
 

Andy98765

Distinguished Member
Just plug the camera into the PC and download onto the PC, once you are using XP you really do not need any other software, open explorer when you get to your pictures click on file view as film strip.
To assist with pictures, red-eye etc open your version of Adobe reader (hopefully you have it installed) click on help, then version updates and hopefully it will offer you a free picture package so that you can clean up your pictures.
 

hig

Standard Member
Already tried that.
I uninstalled the Olympus software and plugged it in.
XP sees it as a storage device and as an extra drive in My Computer, but opening it does the same as with the card in the reader, shows the Olympus folder inside, but when I double click that it says its corrupted and cant read it.
But if I right click the drive and do properties it shows 174Mb used out of the 512 so that sees the pics are there, so why wont explorer???

Again put back in camera and can view all files in view mode...
Got me confused.....
 

hig

Standard Member
UPDATE

Just tried running chkdsk /r from a dos prompt on the card and it took a while but when completed a dir shows files there, so went back into explorer and there they are and now copied across fine.....

YAY!!!
 

The latest video from AVForums

Panasonic HZ2000 OLED TV Review: The best OLED for movie viewing in 2020
Top Bottom