Question Panasonic TX-L32G20B ‘no service’ on FreeSat

unclefib

Standard Member
Hi all,

Helping a friend in Republic of Ireland (cheaply). Got a TX-L32G20B which I know is old, and this may be the cause of the issue.

Rented house with old Sky satellite dish, previous renter said was working, twin cable with good connector coming into the house.

TV works on DVD with SCART and HDMI inputs from computer.

Dish is only providing a single room - dish is mounted above lounge, twin cables come down and straight into lounge. No internet connection etc, just TV plugged into power and one of the sat cables screwed in.

The TV has Freesat and Freeview build in, I screwed one of the twin cables in (TV only has a single socket), also tried the other cable, get exactly the same result.

After auto-tuning, have a full TV guide, up to date programs, listings, HD or SD etc. Information button also shows the content of the show. Press OK to watch ANY station and TV screen goes black and ‘No service’ is displayed in a white rectangle with red writing. Same for the radio stations etc.

I reset the TV to factory settings, have retuned with either FreeSat, or ‘Other Sat’ and get same result.

I’m definitely getting ‘No service’ and not ‘No signal’

Doing some reading it seems the older Panasonics had issues with FEC (but would this only be on the ITV or cause everything to fail?

I need to double check the power is on to the LNB (advised on another site) but having done a factory reset and checked the firmware i would have thought the LNB power would have been set to ‘on’.

So - it could be the TV FreeSat tuner has given up the ghost. TV works fine on SCART and HDMI inputs. OR, previous owner had a Sky Box - and does that only work with their dish? I thought as I am getting a populated TV guide that everything is OK - saying Astra2 sat.

I understand that you can get the channel list populated but this does not mean you get a signal.
 

Nimiq1

Active Member
Could the previous tenants have had Sky Q? That uses a different LNBF to normal and if so, a swap to a standard LNBF should get you going.
 

unclefib

Standard Member
I have no idea. It was the landlady said ‘it all worked for them’. I had a look at the dish and LNB - they were not new, not rusty, but looked like they had been up a while. Is there any difference between the LNB’s visible from the outside? Any way to determine that?
 

Rodders53

Distinguished Member
Is it a $ky type oval dish?

If so then two cable connections only = $ky Q
Normal $ky LNBs are quad = 4 cable connection points. Often when only two they connect the outer two leaving two more in the middle.

ROI has their own sat service Welcome to Saorsat which is on a different satellite and LNB type. Saorsat - Wikipedia Have you tried a 'non freesat' tune on the TV?
 

unclefib

Standard Member
Hi Rodders. I’ve never owned a dish. So bear with me.

The dish is a grey oval perforated 60cm across with a black/grey LNB and white cap. I’m not there right now but will ask for a photo to check if its 2x or 4x output. The TV is Freesat, Freeview and I’m getting an indoor aerial for the Saorview, rather than another dish for Saorsat. That will come once I get the freesat working.

I tried non freesat tune, resets, factory reset etc and exactly the same thing happens - no service. I’m trying to get hold of any old sat box just to rule out the TV....
 

Rodders53

Distinguished Member
Nothing at all on either sat tuning = in an order of possibility:

1. bad cable connection. Easy to bend over the 'pin' of F-plug (i.e. centre conductor) when pushing in to F-socket of a receiver, so it either has no connection or shorts to the outer. Check and remake if needed.
Try both leads, in turn, if a 'shotgun' twin type.

2. Something is blocking the view from dish to satellite. (Trees, bushes, buildings.)

3. Bad lnb. They can fail. (Also bad connections at lnb).

4. Broken/damaged cable between lnb and receiver. Inspect inch by inch if necessary.

5. Dish not pointing at any satellite as has been moved (wind).

2 and 5 can be fixed by relocating and/or re-aligning the dish.

6. Faulty TV sat tuner.
 

The latest video from AVForums

Podcast: Marantz SR7015 & NAD T 778 AVR + Mission LX2 MKII Speaker Reviews, AV & Film News and More
Top Bottom