Panasonic SC-HTB900EBK Error Code U704 Conundrum

oldfart

Active Member
After getting the SC-HTB900EK last June started getting the Error code U704 " incompatible Video Format ". After several weeks of communicating with my supplier and Panasonic who agreed there was a fault and I should return it for inspection. Was not keen spending £35 for the privilege to have it collected but bit the bullet and had it collected last Monday.

Monday evening received a call from the service engineer who told me they could find no fault, he then asked me what if anything was connected to the sound bar and when I told him a apart from the TV in, a Panasonic DMP-UB400 4K player HDMI 1 and an Apple 4K tv HDMI 2 and with that he said " There's your problem " you will need to connect both of them directly to the TV and connect your Freesat box into the sound bar as it was SD/HD only. Apparently the signal from both the Panasonic and Apple TV are incomaptible being older products!. Talking to the engineer again on Wednesday he said if you buy a new product such as the sound bar you would probably need to buy the latest player to almost guarantee compatibility if you want to connect it to the sound bar. Now that begs the question, are we in some way being mislead by manufactures because both the Panasonic literature and on the Amazon web it states,
  • Enjoy high-definition 4K content with no loss in image quality, as video source passes through the system from receiver to your 4K TV.
or am I getting it wrong?.

Now the other question is why did not Panasonic mention this when we was communicating via email regarding the problem as they was given all the facts?.

Finally a word about my supplier who was very helpful all along this process and even offered to give me £20 towards petrol to drive in person to the service centre but was not up for that really.

I am getting the sound bar back on Monday, I connect it up as per instructions and hope the error code does not show up as when it does the sound output gets muted and you need to scroll through the input button to the desired input to get the sound back. To be honest if it does will need to speak to Amazon. What do you think about the situation especially if you have the same sound bar?.
 

Clem_Dye

Distinguished Member
When did the error start? If everything was working normally and the error started out of the blue then I’d suspect a fault. If it started the moment that you connected a new device then that could be a fault with the new device, the bar, or both. Decent HDMI cables are a must (Amazon 18G cables are fine).
 

oldfart

Active Member
The fault stared within a couple of weeks but it was very intermittent i.e, it would go weeks before occurring or could happen 3 times in one night. Right from the start had the DVD and Apple TV connected. All I can do now is play it by ear so to speak and connect up external devices as suggested by the service engineer. I did buy a new HDMI cable from Amazon to see if that would rectify the problem but sadly no. All HDMI leads used are off the same standard. Purchased the sound bar on the 05/06/20.

Screenshot 2020-12-12 at 15.57.51.png
 

oldfart

Active Member
Well it's been over a month since the sound bar was returned and no error code, seems the engineer was right telling me to rearrange the external equipment inputs.
 

The latest video from AVForums

Podcast: Anthem AVM 70 Review, EQing Your Home Cinema Sound System and More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom