Panasonic Plasma 55" ST30 14 blink no picture no sound

Zephar

Novice Member
Replaced the P board with no change; but, further reading seems the A board is the most likely culprit, although the SC/SN are also implicated.
Anyone have additional information that might help me in my adventure to fix my wonderful TV that I was so pleased to purchase back in 2011.
Seemed to be the best TV at the time and 3D with Avatar playing on all the store's TVs looked so awesome. At home it was even better, especially in the dark area it was situated. Now in 2019 I replaced it with an OLED LG which I took back and got a Roku 65" TLC for $600 at Costco. Yes, the OLED was better, but not $3,000 better. Ja ja ja! I can barely notice the edge lighting and the blacks are quite acceptable, although not like the plasma or OLED.
Now, I sure would like to fix my nice Panasonic Plasma which I paid $1,750 I believe. Dang! Surprised to see used ones selling from $500 - $1,100 on eBay!
Got the 2011 - FHD Plasma TV Technical Guide & Troubleshooting Flowchart, which I highly recommend to assist; but, not working daily on TV's places us all in the same boat of some confusion which way to go. The boards are surprisingly inexpensive, and just ordered the A board for $30 with free shipping. They go from $30 to $150 on eBay. The SC/SN are even less, so, should I go ahead an replace these if the A board does not fix? I have read a number of folks replacing Both A & P boards with 14 blinks and still did not fix the TV, and still no picture, no sound, and steady red light after hitting power button. That is exactly what I have symptomatically.
Any help would be most appreciated folks! Thank you in advance.
Best,
Seth
 
Last edited:

Zephar

Novice Member
Tech72,
Thank you so much for the reply. Just received the A-Board ordered on eBay. Looks used, and says refurbished. From all the research online I eventually came to this conclusion; but, then here or AVSForum or perhaps DIY Forum I kept getting these other boards being named and a convincing youtube video about the SU board collecting heat in the upper left corner and shorting out the upper chip, and showing how to add a fan over apparent holes already in place for a fan and connect to a USB input. This was the P55VT30 series however so the boards on the left looking from behind is one big board with 3 spots across the top which really do look like they are for fans; and, indeed that is where it gets the hottest when it was working. What is you opinion on this?
Are you a repair person that sees a lot of these types of problems? The 14 blinks seem to be an undocumented error code, so, get differing opinions. However, I have in 2 separate places that it is 90% A-Board, 10% P-Board, so, I replaced it backwards replacing the Power board 1st. If you have time please let me know what you think and I will post the results of replacing A-Board this week. Any recommendation before I commence the project? And what do you think about adding the fan, as I have several folks saying this is why the boards fail, heat; and, I have a heating duct on the ceiling right above the TV and it is winter here.
Best,
Seth
 

Zephar

Novice Member
Tech72,
I have been somewhat confused as which board is which except the A/B-Boards. I uploaded a file which seems the most accurately labeled. Does it look correct to you?
Best,
Seth Panasonic Board Labeling.png
Panasonic Board Labeling.png
 

Zephar

Novice Member
Here is a picture of the back showing what 'appears' to be slots for fans, either placed inside or outside the back cover.
Seth
3 Fan slots?.png
 

Tech72

Active Member
I'm tv repair, sorry for delay but was busy. Let's go to answers: into upper pic all boards are well labeled with right names. I don't belive you need to install a fan there, never had problems with this tv on SU Board, except when the panel is shorted anyway if you wanna add a fan there I suggest to buy an original fan (from VT30) to place on panel (there are holes to fix it yet) and connect the power on 5v line (usb too is good if you're not able to find the right 5v pin on P-Board). The only problem of 30 series are the loose screws on boards, this mostly causes faulty on SC board. So check all screws on all boards and tighten all, especially the ones on SC-SD-SU-SS board. Be carefully when you buy the A-BOARD it must be the B version (British) and not the E version (European) because this board is the only one different between the European model and British (Irish too) model. If you will install the E version you'll be not able to get terrestrial channels well listed and also you'll not get Freesat funcions. Let me know when you'll replace A-Board, I'm sure your tv will work fine then.
 
Last edited:

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom