Panasonic P42G20B HD sound level

raydawson

Active Member
I've got a new Panasonic TX-P42G20B but have an issue with the sound level on HD channels being very low compared to SD channels.

I'm using my Home Cinema for the sound and so don't have access to the Volume Correction settings.

If I record an HD channel onto a USB drive and play it back, the sound volume is fine. But viewing an HD channel directly, I have to turn the sound right up.

How can I equalise the sound levels when using a home cinema?

I also haven't yet found out how to have different picure settings for different inputs - or at least I haven't been able to find it in the manual.

Any help greatfully received.

Cheers,

Ray D
 

raydawson

Active Member
Further to the above...

The volume change between HD and SD television sound is only on the digital output.

The volume on the TV and also the volume from the analogue output fed into my Panasonic home cinema is the same switching from HD to SD.

But, using the optical out to my home cinema, the HD volume is a lot less than the SD volume.

Can anyone please say is they experience the same thing on their TV - or even give an explanation as to why it might happen?

Cheers,

Ray D
 

paulr2006

Distinguished Member
It's normal & due to the additional processing involved with HD sound, you do however have a volume offset control on the TV to help equalise things :)
 

raydawson

Active Member
It's normal & due to the additional processing involved with HD sound, you do however have a volume offset control on the TV to help equalise things :)
Not if you use the Home Cinema for sound.

It's only the optical output which is low on HD audio - the analogue phonos are fine.

Cheers,

Ray D
 

handful

Active Member
Mine is very quiet on Freeview HD channels but fine on Freesat HD channels. No idea why but I no longer even try Freeview because I was so fed up of forgetting when I changed channels afterwards and getting blasted out by the difference.:mad:

Most of the time I'm on Sky HD now anyway which is also fine for me.:)

Sorry for not helping much!
 

raydawson

Active Member
Thanks for that - it is very helpful to know that I'm not the only one. It's a new TV and I was worried it might be a fault but I've a feeling it might be due to Dolby issues etc on the optical output.

Cheers,

Ray D
 

paulr2006

Distinguished Member
Not if you use the Home Cinema for sound.

It's only the optical output which is low on HD audio - the analogue phonos are fine.

Cheers,

Ray D
That's correct & as I said due to the additional processing involved on the HD sound (Optical) :) it will not apply to the phono's because they are Analogue. Use the volume offsets to compensate.
 

raydawson

Active Member
That's correct & as I said due to the additional processing involved on the HD sound (Optical) :) it will not apply to the phono's because they are Analogue. Use the volume offsets to compensate.
I may be missing something here but, I don't have volume offsets available if I switch the TV to use the external outputs. It's only there when using TV sound, as far as I can see.

Where specifically do I look for volume offsets when on external sound?

Also, how do I set volume offsets for individual channels - ie HD or SD? I thought it was the same for all DVB channels. Again, maybe I'm wrong.

There are obviously a lot more tweaks available than I have found in a week's use of the G20.

Cheers,

Ray D
 

tvbox

Well-known Member
Try pressing OPTIONS and the offset will be called Volume Correction.

Not sure if it will apply to external sound but definately internal sound.
If you are using the Built in tuner, you should be able to set Volume Correction for each channel independently. You can also set VC for each AV input too, but the TV isn't clever enough to distinguish different channels of course.
 

flyfisher1

Standard Member
raydawson - I have the answer for you. Under Menu and choose sound, you don't have the volume correction but you do have the MPEG correction. This only works on the SD channels that are louder on the AV (HDMI) link than your HD channels.
I basically set the MPEG to -12dB which brought the SD channels to the same loudness as the HD channels (which are unaffected by the MPEG correction)

Does this work for you?
 

Trending threads

Top Bottom