Panasonic OLED JZ1000B + Sonos Beam 2 issues


Active Member
Hello folks,
I have a new Panasonic Oled and a new Sonos Beam 2 with surrounds but keep getting sound drop outs everyday.
Both devices are up to date, i have checked all settings on both and tried everything suggested by Sonos, now beginning to think its the TV and not the Sonos which is the problem?
Just wondering if anyone else are having these issues?
It happens on standard terrestial TV on the TV, on the BT box and on all the apps basically everything....except playing music from my phone which also points me towards the Pano being the problem!!!
Any help from you fine folk would be very much appreciated :)


Active Member
Assume you've enabled earc and passthrough on the TV and it's plugged into the earc port?

Out of interest when you get the drop outs, if you go into the sound menu, does it still display as "home cinema" or has it reverted back to "TV speakers" even though it's still plays through the beam.


Active Member
Ok so I’ve now narrowed it down to the Apps on the TV.
Tried beam on a different TV for a few days and no issues with sound whatsoever, put it back on the OLED did a reset.
Sound is fine on all connected devices but when you watch on TV’s apps the problems start, now the sound breaks up write from the off.
On Disney, Netflix and Amazon it’s very noticeable, tried seeing if there is anyway to update the apps on the TV but I cannot see any?
Any clues folks or have I just got an iffy one, will have to keep trying to contact Panasonic 😒


Novice Member
Can you try switching to LAN into your Panny and disable wifi to rule out interference?

I have something similar but different problem that happens to my Arc and Ones but only because I unplug them and don't allow them enough time to boot up before powering up Arc. If I remove surround and enable again it fixes the issue.


Active Member
Get the same problem here, mine is kinda different that the sound works and sometimes around 20/30 seconds in the sound drops out and comes back, seems ok after that. Thinking some sort of handshake problem.

The latest video from AVForums

Paramount + UK launch: Halo, Star Trek and Beavis, and all the latest 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom