Panasonic GZ950 4K OLED Review & Comments

RobTi

Well-known Member
BBC Four HD, BBC News HD and Quest HD are all on the often-problematic COM 7 mux which can usually be picked up at UHF channel 55 when tuning. This mux is outside of the ideal range of certain types of aerial, is often broadcast at a lower power than the others and is also susceptible to interference in certain types of weather. Some of the UK's transmitters don't broadcast it at all.

You could start by checking the signal strength you get for a non-problematic channels (try BBC One) and compare it with BBC Four HD. Do this by selecting the relevant channel and then go to 'Signal Condition' in the Freeview tuning menu and make a note of the signal quality and strength. My guess would be the BBC 4 HD values will be a lot lower, which will explain the issue.

Channels returning to their original positions after retuning is normal behaviour, BTW.
Thanks I knew my main channels were 100% quality but checked these ones and below 50%, can’t understand why they disappear rather than show no signal
 

dvdmike

Well-known Member
So anyone noticed anything different with the firmware update?
It's not often they do one
 

Buckster666

Well-known Member
So anyone noticed anything different with the firmware update?
It's not often they do one
Haven't noticed anything different, it appears 2018, 2019 & 2020 models all got a similar update
 

mikej

Well-known Member
When a new firmware is released, you normally can't use any of the apps without first doing the update but I watched Netflix last night on my GZ without any prompting.

Ignore that ! One of my kids casually informed me that the update installed when they watched Netflix the other night. I've told them to tell me in future :D
 
Last edited:

dvdmike

Well-known Member
Haven't noticed anything different, it appears 2018, 2019 & 2020 models all got a similar update
When I saw it pop up I was hoping for Disney + lol
 

Spencem

Active Member
Mine has stopped getting a DHCP IP address on the 5Ghz WiFi, rebooted the TV and the router, but no change. 2.5Ghz works fine but going back to 5Ghz it stops picking up an address again.
Not a problem as I've simply given it a static address, but a bit odd.
 

Buckster666

Well-known Member

IT Troll

Well-known Member
Anything that falls out of this 'perfect fit' range, 25fps and 50fps for example, I'm not 100% sure on how it's made to fit but, I'd suspect it's a combination of speed changes and pulldown.
I think they tend to switch to a 100Hz output mode when receiving a 50fps input.
 

Soshen

Member
Hello i need a info.
I've a Yamaha RX-V581 that support ATMOS, but when i try ATMOS losses from Netflix app it get only DD+ as audio not ATMOS via ARC.
There are some settings on TV that must be active for send ATMOS from netflix app to amplifier?

Thanks
 

kbfern

Distinguished Member
Atmos will not pass from the Netflix onboard ap to the Yamaha via ARC it only passes as DD+. If you want to get Atmos from Netflix to the Yamaha you will need Netflix from an external source like a firestick 4k or other streaming device.
 
Atmos will not pass from the Netflix onboard ap to the Yamaha via ARC it only passes as DD+. If you want to get Atmos from Netflix to the Yamaha you will need Netflix from an external source like a firestick 4k or other streaming device.
No, that is not correct. My TV Netflix app passes Atmos over ARC.
 

Fillius

Well-known Member
Atmos will not pass from the Netflix onboard ap to the Yamaha via ARC it only passes as DD+. If you want to get Atmos from Netflix to the Yamaha you will need Netflix from an external source like a firestick 4k or other streaming device.
The GZ950 can pass DD+ with Atmos over ARC from the internal Netflix app just fine. Are you meaning the limitation is on the Yamaha end?

Hello i need a info.
I've a Yamaha RX-V581 that support ATMOS, but when i try ATMOS losses from Netflix app it get only DD+ as audio not ATMOS via ARC.
There are some settings on TV that must be active for send ATMOS from netflix app to amplifier?

Thanks
Atmos will need to be enabled in the sound menu, but it should be by default. What else do you have plugged into the TV? Some others have had issues with GZ series TV's not detecting Atmos support in the apps when HDMI CEC is enabled on another device like an OPPO 203, and I think a particular Sky box.

One thing that's always worth trying. Turn off the TV, turn it off at the plug and leave it for a few minutes, then switch it back on and see if the Netflix app now shows the Atmos label.
 

mikej

Well-known Member
From memory, I thought the GZ wasn't supposed to (officially) output 'full' Atmos but 'lossy' Atmos was possible provided audio out was set to PCM / Bitstream ?
 

Fillius

Well-known Member
From memory, I thought the GZ wasn't supposed to (officially) output 'full' Atmos but 'lossy' Atmos was possible provided audio out was set to PCM / Bitstream ?
That's right, except for the PCM bit, it would need to be bitstream to pass anything other than 2 channel PCM.

eARC supports full lossless Dolby TrueHD Atmos and Dolby MAT Atmos, but ARC only supports lossy Atmos in the form of DD+ Atmos.
 

dion 6

Active Member
Atmos will not pass from the Netflix onboard ap to the Yamaha via ARC it only passes as DD+. If you want to get Atmos from Netflix to the Yamaha you will need Netflix from an external source like a firestick 4k or other streaming device.
As the guys above have said my gz950 netflix app passes atmos to my avr with no problems have a look in the sound settings in the menu and make sure its set to atmos on it should be by default but check anyway. The GZ950s amazon prime app doesn't support atmos so I use a 4k firestick for that and Disney plus
 

dion 6

Active Member
Hello i need a info.
I've a Yamaha RX-V581 that support ATMOS, but when i try ATMOS losses from Netflix app it get only DD+ as audio not ATMOS via ARC.
There are some settings on TV that must be active for send ATMOS from netflix app to amplifier?

Thanks
Menu settings sound atmos on
 

Soshen

Member
The GZ950 can pass DD+ with Atmos over ARC from the internal Netflix app just fine. Are you meaning the limitation is on the Yamaha end?


Atmos will need to be enabled in the sound menu, but it should be by default. What else do you have plugged into the TV? Some others have had issues with GZ series TV's not detecting Atmos support in the apps when HDMI CEC is enabled on another device like an OPPO 203, and I think a particular Sky box.

One thing that's always worth trying. Turn off the TV, turn it off at the plug and leave it for a few minutes, then switch it back on and see if the Netflix app now shows the Atmos label.

Only a ps5.
I've checked the ATMOS is active on TV

My yamaha fully support atmos, reading the manual.
Thanks
 

scorxpion2012

Standard Member
Hello, just a quick question logo luminance settings should be set on low or high. Kindly if u can elaborate because I am thinking high should protect the screen from burn in.
 

mikej

Well-known Member
Hello, just a quick question logo luminance settings should be set on low or high. Kindly if u can elaborate because I am thinking high should protect the screen from burn in.

The 'High' setting presumably provides the most protection. I have mine set to High and haven't noticed anything detrimental.
 

CPR

Novice Member
All, You Tube app in my TV is suddenly stopped working and give me “Network Error “. Netflix and Amazon apps are working fine so it is not to do with internet. Tried to uninstall and reinstall the app but no luck. Any other tips from anyone or anyone facing similar issue? Thanks
 

The latest video from AVForums

Podcast: LG C1 OLED + JBL Synthesis SDR-35 First Thoughts, plus TV Show & Disc Reviews & more
Subscribe to our YouTube channel

Latest News

What's new on UK streaming services for June 2021
  • By Andy Bassett
  • Published
Austrian Audio launches Hi-X65 headphones
  • By Andy Bassett
  • Published
Roku expands streaming content with Roku Originals
  • By Andy Bassett
  • Published
What's new on Netflix UK for June 2021
  • By Andy Bassett
  • Published
AVForums Podcast: 12th May 2021
  • By Phil Hinton
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom