Quantcast

Panasonic GZ OLED Series Owners Thread

thedoswells

Well-known Member
Hmmm The ultra HD football trial also reports 1080i.
it says uhd in iPlayer. I’ve tried it on both android and iOS versions of the app.
This is on the 65gz950.
Al
It's odd as mine still reports 3840X2160. 55" gz950 here. Not sure why.
Assume you have a good BB speed?
 

Mr109

Active Member
It's odd as mine still reports 3840X2160. 55" gz950 here. Not sure why.
Assume you have a good BB speed?
Yeah 65meg. Roku SS+ plays it fine and the tv plays Netflix at 4K. I don’t know whether it was just tonight. I’ll try again tomorrow and see if I can see what internet speed the tv is getting, although the roku is plugged into it and it’s fine.
I was hoping to cut down on devices, but the 4K Apple TV doesn‘t like hLG, now the tv doesn’t like 4K in iPlayer. ***!!
Al
 

thedoswells

Well-known Member
Yeah 65meg. Roku SS+ plays it fine and the tv plays Netflix at 4K. I don’t know whether it was just tonight. I’ll try again tomorrow and see if I can see what internet speed the tv is getting, although the roku is plugged into it and it’s fine.
I was hoping to cut down on devices, but the 4K Apple TV doesn‘t like hLG, now the tv doesn’t like 4K in iPlayer. ***!!
Al
I have to say I have found some of the internal apps and external devices to be a bit flakey but I can usually find something that plays what I want, how I want it. 7 world's did look incredible again tonight so I'm happy to live with a few glitches and hopefully more firmware updates will move us the right direction
 

thedoswells

Well-known Member
Just wondering now if its the app causing the issues. It now seems to be reluctant to change the signal details consistently.
 

Blueking

Active Member
Thanks for all the replies on the trouble we are having with FreeView Play and the streaming services on the new TV’s. We had a network outage in our area from Virgin yesterday for quite a few hours. So far although I haven’t started to test it thoroughly we haven’t seen the steaming issue (yet). I wonder whether there was some kind DNS resolution failing on their side that’s now been fixed. I had also tried changing the DNS to google 8.8.8.8 and open 1.1.1.1 on both TV sets a few weeks back but it had no effect. I’ll keep you posted on developments. Also if anyone else has similar issues please post on the thread.
I’m really hoping that the issue is resolved or resolved with the next firmware update.
The picture quality on both of these sets is superbly natural I’ve been extremely impressed with everything we’ve watched on it so far. It does a great job even with standard def images and straight DVD. At the other end of the spectrum watching the 4K master of Don’t Look Now last night was beautifully natural. Also watching UHD streaming of the BBC Seven Worlds with the kids was superb. Watching earlier in the week the Arrow release of Thief was ace, beautiful depth to each Blu-ray frame. It does incredibly well with non UHD/4K content which gets a big thumbs up.
Clearly watching the Interstellar or Dunkirk 4K UHD discs is always going to be quite eye opening experience from flicking through them this week.
Before we bought the two new GZ’s, I had a good look, spent ages in JL and others checking out the Samsung’s and LG.
The conclusion I came to after many weeks of looking is that the Panasonic keeps the moving images as natural as possible. The difference with the other (also very good) panels by Sam and LG is that they seem to always be trying to add something to the images that is not as natural as the Panasonic.
I’ve also spent some time checking through the GZ picture menu setup. I can post my final setup if anyone is interested.
Whatever the outcome with the streaming issue I will get back and call Panasonic and have a chat with them again depending on what happens.
Just bought another DP-UB820 to go with the second GZ yesterday, should be here today, so will get that setup this morning. The kids are playing MarioKart on the larger set at the mo. The Ninty Switch images look really good.
More coffee now needed after the mornings typing!
I seem the FreeView Play not starting a few times, saw it today after changing some of the internal sat turner settings and switching back to freeview.

I mounted my 65GZ950B on the wall, so not easy to remove the mains power, found I had to switch back to live tv, then switch to standby using the remote and then pressing the bottom rear power button on the back of the tv, till the tv restarted, seemed to do some kind of forced reboot, them freeview play was fine.

Watched last two episodes of seven worlds in UHD, which was 100% rock solid, no streaming issues.

Another issue I have seen is the iplayer beta football loop, trys to start in UHD, see the busy icon, but doesn't start sometimes, if I power off tv (before I mounted it on the wall), the demo loop was again 100% stable.

My GZ950 is using cat6a gigabit wired ethernet with HP enterprise switch, bt hub6 50Mbs /10mbs stable speed.
 

thedoswells

Well-known Member
I seem the FreeView Play not starting a few times, saw it today after changing some of the internal sat turner settings and switching back to freeview.

I mounted my 65GZ950B on the wall, so not easy to remove the mains power, found I had to switch back to live tv, then switch to standby using the remote and then pressing the bottom rear power button on the back of the tv, till the tv restarted, seemed to do some kind of forced reboot, them freeview play was fine.

Watched last two episodes of seven worlds in UHD, which was 100% rock solid, no streaming issues.

Another issue I have seen is the iplayer beta football loop, trys to start in UHD, see the busy icon, but doesn't start sometimes, if I power off tv (before I mounted it on the wall), the demo loop was again 100% stable.

My GZ950 is using cat6a gigabit wired ethernet with HP enterprise switch, bt hub6 50Mbs /10mbs stable speed.
Similar here with iPlayer beta
 

bigelvis

Standard Member
Ok Gents, I've got wall mounted my 65GZ950 yesterday and I can say I'm another happy owner of this set.
For what's it's worth that's my observations regarding this set.
The processing of the SKY HD programs and apple tv HDR/Dolby vision is absolutely faultless so far. I haven't noticed any DSE, macroblocking or banding. DSE was slightly visible on my Sony FALD LCD when camera was panning on white backgrounds, so happy that's it's gone on this oled.
As it turned out Professional 1 mode is little too dark for me - coming from Sony FALD LCD with backlight set up on 5 out of 10. So I set the luminance on 70 and then the brightness is on the same level as on the Sony.
Regarding motion, I switch of completely IFC because in my opinion even on min level it introduces soap opera effect.
I've tested dolby Vision on Mad MAX Fury Road from Apple tv and I think I will be using Dolby Vision Bright mode with default settings. The picture was absolutely stunning.
HDR 10 I've tested on Jack Ryan and Grand Tour on Amazon Prime. Jack Ryan (S2Ep5) looked a bit dark on Pro 1 (Luminance, contrast = 100) so I've switched on HDR brigthness control with enhancer set to 8. Grand Tour was already bright enough without that setting but I haven't noticed any negatives with it On.

What mode/settings are you guys using for HDR10?

As you see that was very limited testing so far so probably it will take more time to settle completely with all settings but I have to say so far so good:)
 

bigelvis

Standard Member
Well, after several months of deliberation, forum trawling, chin rubbing and hanging on for the GZ2000 launch only to end up discounting it for reasons other than the significant price, difference I took the plunge this morning and ordered a TX65GZ950B... almost 10 years to the day since I bought my Kuro KRP500a!

I'm due to get it on Wednesday and have ordered a Lindy HDMI switcher to hopefully overcome my legacy processor issues in the short term at least 🤞

I plan to wall mount and typically it looks like my Pioneer PDK-WM02 Wall bracket has different bolt spacing. 😿

Can any of you kind folks on here make recommendations for a good quality wall mount for the GZ950. Just need it to sit nice and close to the wall with no need for adjustable features.

Thanks in advance for any help with this...
I'm using Sanus LT25 - very good quality, highly recommended.
 

blueboy1873

Active Member
Thanks for all the replies on the trouble we are having with FreeView Play and the streaming services on the new TV’s. We had a network outage in our area from Virgin yesterday for quite a few hours. So far although I haven’t started to test it thoroughly we haven’t seen the steaming issue (yet). I wonder whether there was some kind DNS resolution failing on their side that’s now been fixed. I had also tried changing the DNS to google 8.8.8.8 and open 1.1.1.1 on both TV sets a few weeks back but it had no effect. I’ll keep you posted on developments. Also if anyone else has similar issues please post on the thread.
I’m really hoping that the issue is resolved or resolved with the next firmware update.
The picture quality on both of these sets is superbly natural I’ve been extremely impressed with everything we’ve watched on it so far. It does a great job even with standard def images and straight DVD. At the other end of the spectrum watching the 4K master of Don’t Look Now last night was beautifully natural. Also watching UHD streaming of the BBC Seven Worlds with the kids was superb. Watching earlier in the week the Arrow release of Thief was ace, beautiful depth to each Blu-ray frame. It does incredibly well with non UHD/4K content which gets a big thumbs up.
Clearly watching the Interstellar or Dunkirk 4K UHD discs is always going to be quite eye opening experience from flicking through them this week.
Before we bought the two new GZ’s, I had a good look, spent ages in JL and others checking out the Samsung’s and LG.
The conclusion I came to after many weeks of looking is that the Panasonic keeps the moving images as natural as possible. The difference with the other (also very good) panels by Sam and LG is that they seem to always be trying to add something to the images that is not as natural as the Panasonic.
I’ve also spent some time checking through the GZ picture menu setup. I can post my final setup if anyone is interested.
Whatever the outcome with the streaming issue I will get back and call Panasonic and have a chat with them again depending on what happens.
Just bought another DP-UB820 to go with the second GZ yesterday, should be here today, so will get that setup this morning. The kids are playing MarioKart on the larger set at the mo. The Ninty Switch images look really good.
More coffee now needed after the mornings typing!
Would be awesome to see your picture settings on the GZ950👍🏻
 

blueboy1873

Active Member
Got mine on Saturday Morning. Have too say I never thought I'd find another TV to better my Pioneer KRP-500A but the GZ950 certainly matches it....and obviously betters it with 4k UHD Resolution. I prefer Pro2 but that's just me. Sky Q looks better than it ever has, Netflix almost looks Cinematic, Netflix Calibrated Mode is excellent. And omg 4k UHD HDR Discs with the UB820 have blown me away. Can't praise GZ950 highly enough. Haven't encountered any issues with Apps or lag. Maybe because I'm on VM 500Meg Service. Can only imagine it will get better once Professionally Calibrated. 😀
20191130_100558.jpg
 

Chamberlain

Well-known Member
Im really impressed by the picture too on the GZ950. In most areas it edges the C9, altough for some reason i liked the C9 more for older movies as the GZ950 looks a bit more grainy(gz950 better near black though). For some reason the black levels looked weird to me in HDR content on the C9, the blacks were glowing and looked a bit washed out in the background while the gz950 showed the same amount of details but didnt have glowing/elevated blacks. If i dropped brightness with one click it would help with black levels but would also make the overall pic darker than both the GZ950 and my C8. Dont know If i got a bad panel or if the C9 handles content differently as SDR also had elevated blacks with default brightness.

The negative is that i have a vertical line that can be seen in certain panning scenes, near black scenes rarely shows it, it's just those panning scenes with certain colors in the background. Whats frustrating is that it's just that vertical line, rest of the screen is uniform while my C8 looks way more uneven but only shows it in certain near black scenes. So basically when the C8 shows banding in content it looks worse but it happens more rarely while the Gz950 just have that one subtle vertical line but happens more often. C9 also had some banding but similar to the C9 that it only showed up in those tough near black scenes. The GZ950 looks better with whites too, C9 had some red tint in the middle while the GZ950 basically have no tint.

But the C9 went back today and dont wanna deal with another return so just gonna keep the gz950 because i thought it looked slightly better plus no elevated black levels. Also im not a guy that cares about sound but the sound on the speakers were very bad even for me but decided to connect Logitech PC speakers i wasnt using anymore and it works perfect. Wish i had thought of that earlier because they only cost me about £100 and sounds absolutely miles and miles better than the LG SJ9 soundbar i had like over a year ago which were 5 times as expensive
 
Last edited:

Gazgum

Well-known Member
The negative is that i have a vertical line that can be seen in certain panning scenes, near black scenes rarely shows it, it's just those panning scenes with certain colors in the background. Whats frustrating is that it's just that vertical line, rest of the screen is uniform
As far as I’m aware you’re the first to report vertical banding visible in content on here;very sorry to hear that.
As much hassle as it is returning,I’m not sure I would accept that.By my reckoning Panasonic do appear to have better QC re: panel uniformity so just on that basis alone I find it even more disappointing.
 

stevew117

Active Member
That’s something that I have tried previously but as far as I can see everything is switched on at a normal level.
It seems to be anything that’s related to FreeView Play. We have a very good aerial signal also.
I wonder whether there is something odd going on with maybe not only the TV’s but also the Virgin router which we had installed when we moved into the house at about the same time the new TV’s arrived.
Powering the TV off and on always fixes it but standby causes it.
I was hoping somebody else on the forum would have experienced similar things.
As an aside it’s a stunning picture once setup, spent some time on that when they arrived.
Very natural images compared to say LG or the Samsung’s that I compared!
Come on guys I need help otherwise the wife will have me change across to something else!
I've had this happen a couple of times - it is very annoying as Netflix etc. still work (so the network connection is basically OK). One useful thing to know is that there is actually an ON/OFF switch on the back ot the TV, it's at the right-hand side at the bottom of a small cluster of controls. I've used this when Freeview Play doesn't work and it has always fixed it. Much easier than hunting around for the power plug...
 

sirbadger

Active Member
The Picture button came up as standard on my Harmony 650 when I added the 950 as a device. I just needed to add it into the remote's screen since I don't have a hard button for it.
On mine picture was mapped to aspect, not the actual picture button.
 

stevew117

Active Member
On mine picture was mapped to aspect, not the actual picture button.
...on a related note, does anyone know why the Aspect options are so limited on this TV compared to my old Panasonic plasma? That had loads of different aspect/zoom options which would occasionally come in handy when (say) a file on a USB stick was badly encoded. This TV only seems to have a couple of aspect modes and the "other" one was next to useless when I tried it. :eek:
 

Chamberlain

Well-known Member
As far as I’m aware you’re the first to report vertical banding visible in content on here;very sorry to hear that.
As much hassle as it is returning,I’m not sure I would accept that.By my reckoning Panasonic do appear to have better QC re: panel uniformity so just on that basis alone I find it even more disappointing.
Think thats mostly the GZ2000, pretty sure GZ950 is the same as the rest with uniformity. Here in Sweden it's only those smaller retailers that sell the Panasonic TV:s as well and they are pretty strict with returns . I've only had it since thursday so gonna see how it develops.
 

WrittenInC

Novice Member
I've been in touch with Panasonic basically asking if there's any hope in hell eARC will implemented in a future software updated or is it impossible due to hardware limitations? 2 different people via email have notified me that the GZ950 does indeed have eARC. I'll do some testing tonight with my blu ray player to confirm...
 

blueboy1873

Active Member
As yet I haven't seen any Banding or Uniformity issues on mine. Could be that Panel Variance Lottery thing. That's no consolation for any owners of a GZ950 though is it. Contact Panasonic expressing your disappointment in one of their 'Hollywood to the Home' Products. They may.be helpful and demonstrate excellent Customer Service with you. Also the more Customers and Owners that Contact them about it will prompt a Firmware fix.
 

thedoswells

Well-known Member
I've been in touch with Panasonic basically asking if there's any hope in hell eARC will implemented in a future software updated or is it impossible due to hardware limitations? 2 different people via email have notified me that the GZ950 does indeed have eARC. I'll do some testing tonight with my blu ray player to confirm...
that’s worrying if people from Panasonic are saying that...
 

nkb156

Standard Member
Hi, I wonder if you guys could help us out with our new GZ950 TV’s? Bought both a 55 and 65 from JL as a present for the new house. Both TV’s have a very annoying issue that following 2 calls with Panasonic support is still not fixed. FreeviewPlay and the other online streaming services seem to fail if the TV is placed into standby. The only way to get it working again is a power on/off at the plug socket which is tedious as they are placed behind the TV’s on the wall. Has anybody else experienced the same issue? It’s very odd as YouTube streaming works etc. It’s also very annoying considering iplayer is the most used app. We use Virgin Cable with their latest hub router if that’s in any way related. Any advice on this would be most helpful, thanks!
Hi Mallen I also have this issue on the GZ2000. And a few other people over on that thread also experience it. I have great AV signal and fast broadband. No other apps are showing any issue. Like you I use the power off button at the back to reset this. Seems to work for a few days and then issue returns.
 

Moonda

Active Member
If someone has a Harmony they have to teach it the command from the original remote as it’s missing...
Yeah, we can’t even do that as our region’s remote has a “Menu” button where your Picture button is. Australian GZ remote’s don’t have a Picture button at all...

What helps somewhat though, is that picture modes on HDMI ports are retained, & since I like to use THX Cinema for movies, when switching to the HDMI port that my 4K player’s connected to, the TV switches from the daytime picture mode to THX Cinema.
 

Paul Philpott

Active Member
I've been in touch with Panasonic basically asking if there's any hope in hell eARC will implemented in a future software updated or is it impossible due to hardware limitations? 2 different people via email have notified me that the GZ950 does indeed have eARC. I'll do some testing tonight with my blu ray player to confirm...
What was the outcome of your tests?
 

Thatsnotmynaim

Well-known Member
Yes that’s a good solution if you use tour tv as the hub. I do t I use my amp as the hub as also have a pj. Would be good if the Harmony DB has one press buttons for modes so you could build in changing to THX or Pro2 when you switched to DVD etc...
 

Mr. Mer

Active Member
One more sleep for me before my GZ950 arrives but I suspect it'll take a 'day or three' before I can get the KRP500a off the wall and start setting things up properly...
 

Similar threads

Trending threads

Latest News

Dolby Atmos Music comes to Tidal streaming service
  • By Andy Bassett
  • Published
Samsung TVs unexpectedly losing access to BBC iPlayer
  • By Andy Bassett
  • Published
Bowers & Wilkins to release updated Formation Home app in 2020
  • By Andy Bassett
  • Published
SVS launches 2000 Pro Series subwoofers
  • By Andy Bassett
  • Published
McIntosh MC901 Dual Mono Amplifier announced
  • By Andy Bassett
  • Published
Top Bottom