Panasonic DP-UB420P-K Dolby Atmos Issue

blanqshot

Novice Member
Hi. Somewhat a first time here.

So I bought an open box of a Panasonic DP-UB420P-K because I wanted to get into 4K UHD disks since I’ve heard they are far superior then 4K streaming. My mind was blown when I played my first 4K movie.

Anyways, recently I bought a Sonos Arc and I want to use it to it’s most potential.
My current issue is that I cannot have my Panny to output Dolby atmos audio from the player. I have tried the following:

1.) DAO to Bitstream and having Secondary Audio to off
2.) Turned off 7.1 multichannel downgrade option on the last option of advanced settings in the HDMI section of the settings.
3.) Factory reset my Player three time via holding the OK, Yellow and blue button etc
4.) After factory reset I’ve unplugged my player from power physically and waited couple minutes, rinse and repeat, same problem persists.
I know I am not getting Dolby Atmos or TrueHD from my player because:
1.) When I hit Playback Info, on the HDMI Video Out row on the very right hand side it says “Dolby Digital”.
2.) Also when I check my sonos app for my sonos arc it says “Dolby Digital 5.1”.
-

My current setup:
1.) Panny -> to HDMI 2(ARC) on my SAMSUNG QN65Q70RAFXZA 2160P S.
2.) SAMSUNG QN65Q70RAFXZA 2160P S HDMI 2(ARC) to Sonos Arc HDMI.
-

I know my setup works because I’ve used the Apple TV APP on my samsung tv and played The Martian and when I checked my Sonos App it tells me “Dolby Atmos” CLEARLY. I’ve also played Mission Impossible: Rogue Nation and that says “Dolby Atmos” as well.

The titles I’ve tried playing on my Panny are:
1.) John Wick (first movie).
2.) 1917.
and the back of those movies and on the 4K UHD disks clearly says support for Dolby Atmos.

I am pulling hair on my frustrations and I do not know what I am doing wrong. The video out out is good, no issues there, it’s just Dolby Atmos. I’ve also returned the Panny to Best Buy and bought a new Panny, the same model (NOT open box this time) and I just tried the same setting with the same problem.

I have a HDFury Arkana on the way today and I hope that solves that problem but I am mind blown on how hard it is to have this straightened. I’m asking the AVFORUMS community for help. I’ve tried the search settings and I’ve found similar posts related to the UB820 player and they recommended factory reset from what I’ve read.

I also had a BestBuy rep tell me as I was exchanging my old player for the new one that the UB420 doesn’t support it. I call that crap because when I looked up the UB420 manual, US version, page 31 states how to set it up with DAO to Bitstream and Secondary Audio to off. I don’t know what to do besides pray that the HDFURY magically fixes it.

Does the Panny thinks the hdmi out to my tv’s hdmi in can’t support Dolby Atmos so it defaults to Dolby Digital? YES I’ve checked to make sure all movies on the Top Menu for audio setting is set to “English TrueHD” or “English Dolby Atmos”

I’m sorry for this complain but does anybody have any solutions/ideas? I’m seriously considering returning this product and save for the UB820 or the UB9000 if this problem is not fixed. Thank you.

TLDR: Panny outputs Dolby Digital, followed DAO to Bistream and Secondary Audio to OFF and 7.1 multichannel to OFF. Problem still persists. Exchanged old player to bestbuy for a new player of the same model. Same issue. Panny is connected directly to Samsung TV via HDMI. No AV receiver.
 

Attachments

  • 044AF6F0-9734-44B2-8584-CD66B01D80BA.png
    044AF6F0-9734-44B2-8584-CD66B01D80BA.png
    121.4 KB · Views: 40
Last edited:

gibbsy

Moderator
Welcome to the Forum.

All, or at least the vast majority of players, will only 'output' Dolby Atmos as part of the Dolby TrueHD bitstreamed format. The Atmos is metadata attached to that Dolby TrueHD, regardless of whether it's 5.1 or 7.1. It's not the player that is at fault but the decoding amp.

The amp must have at least two speakers in the Atmos domain and configured correctly, ie 5.1.2. If you don't have that speaker configuration then you will not be getting Atmos, certainly from the Panny player.

Using ARC you are limited to SD audio, so no Atmos. You would need eARC to be able to pass through HD audio and Atmos. I've no idea if Sonos is eARC capable but both it and TV would need to have eARC. If either one is standard ARC then no HD audio.
 

goingoingong

Distinguished Member
Hi. Somewhat a first time here.

So I bought an open box of a Panasonic DP-UB420P-K because I wanted to get into 4K UHD disks since I’ve heard they are far superior then 4K streaming. My mind was blown when I played my first 4K movie.

Anyways, recently I bought a Sonos Arc and I want to use it to it’s most potential.
My current issue is that I cannot have my Panny to output Dolby atmos audio from the player. I have tried the following:

1.) DAO to Bitstream and having Secondary Audio to off
2.) Turned off 7.1 multichannel downgrade option on the last option of advanced settings in the HDMI section of the settings.
3.) Factory reset my Player three time via holding the OK, Yellow and blue button etc
4.) After factory reset I’ve unplugged my player from power physically and waited couple minutes, rinse and repeat, same problem persists.
I know I am not getting Dolby Atmos or TrueHD from my player because:
1.) When I hit Playback Info, on the HDMI Video Out row on the very right hand side it says “Dolby Digital”.
2.) Also when I check my sonos app for my sonos arc it says “Dolby Digital 5.1”.
-

My current setup:
1.) Panny -> to HDMI 2(ARC) on my SAMSUNG QN65Q70RAFXZA 2160P S.
2.) SAMSUNG QN65Q70RAFXZA 2160P S HDMI 2(ARC) to Sonos Arc HDMI.
-

I know my setup works because I’ve used the Apple TV APP on my samsung tv and played The Martian and when I checked my Sonos App it tells me “Dolby Atmos” CLEARLY. I’ve also played Mission Impossible: Rogue Nation and that says “Dolby Atmos” as well.

The titles I’ve tried playing on my Panny are:
1.) John Wick (first movie).
2.) 1917.
and the back of those movies and on the 4K UHD disks clearly says support for Dolby Atmos.

I am pulling hair on my frustrations and I do not know what I am doing wrong. The video out out is good, no issues there, it’s just Dolby Atmos. I’ve also returned the Panny to Best Buy and bought a new Panny, the same model (NOT open box this time) and I just tried the same setting with the same problem.

I have a HDFury Arkana on the way today and I hope that solves that problem but I am mind blown on how hard it is to have this straightened. I’m asking the AVFORUMS community for help. I’ve tried the search settings and I’ve found similar posts related to the UB820 player and they recommended factory reset from what I’ve read.

I also had a BestBuy rep tell me as I was exchanging my old player for the new one that the UB420 doesn’t support it. I call that crap because when I looked up the UB420 manual, US version, page 31 states how to set it up with DAO to Bitstream and Secondary Audio to off. I don’t know what to do besides pray that the HDFURY magically fixes it.

Does the Panny thinks the hdmi out to my tv’s hdmi in can’t support Dolby Atmos so it defaults to Dolby Digital? YES I’ve checked to make sure all movies on the Top Menu for audio setting is set to “English TrueHD” or “English Dolby Atmos”

I’m sorry for this complain but does anybody have any solutions/ideas? I’m seriously considering returning this product and save for the UB820 or the UB9000 if this problem is not fixed. Thank you.

TLDR: Panny outputs Dolby Digital, followed DAO to Bistream and Secondary Audio to OFF and 7.1 multichannel to OFF. Problem still persists. Exchanged old player to bestbuy for a new player of the same model. Same issue. Panny is connected directly to Samsung TV via HDMI. No AV receiver.
The atmos from the apple TV app will be DD+ atmos not True HD atmos.
Don't know but I suspect the TV can't pass full True HD atmos via e-earc.

You will need to connect like this to get atmos from UHD.
UB420 HDMI video port-->TV
UB420 HDMI audio port-->Sonus.
or
UB420 HDMI video port-->Sonus-->TV if the Sonus can pass through 4K video to the TV.
 

blanqshot

Novice Member
Problem solved:

HDFury Arkana fixed it.

As soon as I plugged it in today Panasonic automatically pushed out Dolby TrueHD via the HDMI out to the HDFury Arkana. It seems like my TV wouldn't accept the Panasonic's TrueHD audio detail through the HDMI port on my TV and Panasonic identified and no details are shown (software huh) that my tv was the issue and instead kept the signal as "Dolby Digital". The HDFury Arkana is able to receive the full audio signal so Panasonic recognized the signal and put on the Playback Info as "Dolby TrueHD" and I was able to push out Dolby Atmos via my Sonos Arc with no issues.

Unfortunate that Panasonic can't talk saying my TV is incapable of receiving Dolby TrueHD signal. Lesson learned. Many hours spent pulling hair.
 

The latest video from AVForums

Podcast: Anthem AVM 70 Review, EQing Your Home Cinema Sound System and More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom