Panasonic DMR-HWT150 - Won't switch on


Novice Member
Panasonic DMR-HWT150 - Won't switch on!
Pressing ON button on machine does nothing. Using ON button on remote does nothing. Removed power cable, waited a minute, plugged back in and the green initiation light flashes for a while, as if it was initiating, but then it just goes off and the red ON light does not light.
Any ideas as to what to try next?
Machine started fine 24hrs ago!


Welcome to the forum.

Unfortunately there is probably not a lot you can try.

Evidently some problem is preventing the power supply from starting up - quite probably the power supply itself.

It is usually the sort of problem requiring bench analysis.


Novice Member
Tried removing power lead a number of times, left machine alone for several hours without power lead in, plugged lead back in and tried the remote.....Hey Presto!!...the flashing "Initiating" light finally stayed on and the machine now responds to remote control commands.
The wonders of modern machines. All sorted...for the moment anyway.

The latest video from AVForums

Podcast: Panasonic JZ2000 Final Thoughts - TV Calibration: Should you? And More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom