Panasonic DMR BS-750 sudden loss of picture

Bert Coules

Well-known Member
My trusty Panasonic DMR BS-750 Blu-Ray recorder/Freesat receiver, bought new just after they were first released and connected to a Marantz amp via HDMI, yesterday suddenly lost its picture. As far as I can tell, everything else is still working perfectly: it's just the video output that's gone.

I haven't yet had a chance to try one of the other outputs, but am I likely to be right in thinking that they will probably be fine and this is an HDMI fault? If so, is it a known problem and is there a fix?

Many thanks.
 

Gavtech

Administrator
It is not a known problem - to me at least.

The first thing to do is to eradicate the possibility of a software or chip level glitch by resetting both the unit AND the TV by unpowering both devices for a period ( say 10 minutes) then reconnect and try again.

Try another HDMI lead if that produces no results.

If still nothing, test the other outputs.
 

Bert Coules

Well-known Member
Thanks for that. I did power down the unit last night but not the projector or the amp (both of which continued to work perfectly with other inputs). I'll do some experimenting today and see what happens.
 

Bert Coules

Well-known Member
I seem to have solved it: using one of the non-HDMI outputs (which were all working perfectly) I went into the Panasonic's setup menu: HDMI video format was set, as ever, to Automatic. Changing it to 1080i restored the HDMI picture. Presumably the auto facility has developed a fault - I wonder if it's a sign of further problems to come?

.
 
Last edited:

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom