• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Outfit Demo is on Marketplace

Mine was quick I must have just beat the rush. Now as for the game. WOW. One word to sum it... Rubbish. LOL. Rubbish graphics and controls. I wasn't looking forward to this anyway but its just all too confusing. Maybe with practise it could become fun but the graphics look UGLY.
 

AVRocky

Active Member
Why is it going so slow? Bandwidth issue?
 

Munkey Boy

Distinguished Member
Took about 15 mins to download the lot for me on my 10Mb line. BUT, I can't start the game - I just get an error message telling me I can't play on PAL-50, I need to change my settings to 60Hz?!? :confused:

Am running on a component cable at 720p.
 
R

rottyman

Guest
This game does not support pal-50. Please change your display setting to pal-60????

Im in pal 60hz mode as far as i know. Im using vga cable at 1360x768 but i still get that nag screen ????
Also i had doa4 running fine on my machine and that needed 60hz mode to run.
 

Steve-L

Well-known Member
I can't even get it to work! :thumbsdow

Says it doesn't support PAL-50... I'm using the Microsoft VGA cable on my Plasma and have no options to change this... I can run the PAL-60 DOA4 without a hitch... what is it going on about? :mad:

EDIT: At least it aint just me then...
 

AVRocky

Active Member
Mine has downloaded like 20MB in 10minutes...wtf is that! I can download 200MB in that time!
 
X

Xeroxtc

Guest
Move the switch on your lead to Normal TV (as opposed to HDTV setting), options should then appear in display settings.:smashin:
 

Steve-L

Well-known Member
Xeroxtc said:
Move the switch on your lead to Normal TV (as opposed to HDTV setting), options should then appear in display settings.:smashin:

Yeah, but that wont work for those of us with VGA cables :(
 
R

rottyman

Guest
Ive just deleted mine gonna try and download it again now see if it makes any differ.

Im using the joytech vga cable but cant see why it would be a problem??
 

stepp

Active Member
I wouldnt bother...i played it for half hour....its slow, boring, the graphics are nothing more than an xbox game etc etc....i will not be paying for this NO WAY.

How the hell could they look at that and think " yeah were release that, it looks good ".....ive actually seen better graphics on the xbox.
 

AVRocky

Active Member
I was monitoring the details of my router and it said (at a particular moment) that it had downloaded 15.2MB (in about a minute), yet the demo has only gone up two percent, meaning it has downloaded around 8.8MB in that time. Wtf is that about?

How can that work?
 

AVRocky

Active Member
Munkey Boy said:
OK guys, I've found a fix. Go to composite, change settings to PAL-60, then switch back to component and you can play in 720p! :smashin:

Lol imagine if Steve deleted it, then he'd have to download it all over again :thumbsup:
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom