Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

Optoma H57. Any issues ?

Discussion in 'Projectors, Screens & Video Processors' started by The Vorlon, Dec 24, 2004.

  1. The Vorlon

    The Vorlon
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I currently have an Optoma H57 on order but won't be receiving this now until the new year unfortunately :(. I would be really interested to hear if anyone who has been lucky enough to get theirs has had any problems/issues/gripes with this projector ?
     
  2. ds_kerr

    ds_kerr
    Standard Member

    Joined:
    Apr 24, 2002
    Messages:
    32
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Hi there,

    I got my Optoma H57 earlier this month and I have been very happy with it. This was my first projector so I have nothing to compare it with.

    Picture quality is excellent, it is very quiet as well which was a big plus with the wife. Remote looks a bit naff but functionally is fine. I have not seen rainbows but as this is my first projector I have no comparison. I have tried to avoid searching for them for this reason.

    I will be taking time now over Christmas and New Year whilst I am off to really start testing it, I am using component and dvi cables to connect it to my HTPC, SKY+ etc.

    Good luck,
    Dave.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice