• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Oppo bdp-93 multi-zone blu-ray

BillyBoss

Standard Member
My Oppo bdp-93 multi-zone blu-ray player that i bought from Progressive Audio Visual dose not play some zone B films from company's like Lionsgate and Weinstein, it plays all imports zone A. So does anybody know of a solution as i do not want to ship it back to Progressive
 

MDPlatts

Established Member
Have you a) upgraded the firmware then/and b) factory reset it - and if you have the pro-kit - did you press "2" to power the player on? (I don't know how you do the non-pro version). I've played some lionsgate films recently with no problems - and similarly weinstein. I'm presuming its an official EU model - not a grey import.
 

BillyBoss

Standard Member
yes its the EU i got it from Progressive Audio and it as the latest firmware I havent factory reset it as yet, I have just tried several other films that are zone locked from other companies and it seems as though it wont play any film that is B locked, only zone free or the USA zone A
Thanks for your time
Billy
 

MDPlatts

Established Member
Are you powering up by pressing "2" on the remote or "power" - the former will select zone "B" - the latter will select "A" (or last power-up-zone).
 

Jon_C

Established Member
Yep, sounds like there is nothing wrong with your player, Billy - you just have it on region-A mode. You need to change regions as the others have said.
 

Avi

Distinguished Member
Depending on the title if the player rejects it due to wrong region it may not play when you select the correct region unless you first erase BD video data from the Oppo's persistent storage.

Avi
 

Member 518284

Distinguished Member
Billyboss

send me an email and i`ll send you a pdf showing how to change region if its the pro version kit fitted

this should have been supplied, but its really very simple, if its the other cheaper kit its a bit of a pain but still quite straight forward it you have fast fingers lol.

Allan @ ideal AV
 

BillyBoss

Standard Member
Billyboss

send me an email and i`ll send you a pdf showing how to change region if its the pro version kit fitted

this should have been supplied, but its really very simple, if its the other cheaper kit its a bit of a pain but still quite straight forward it you have fast fingers lol.

Allan @ ideal AV
Thanks Allen its bboland {at} hotmail {dot}.co.uk
 
Last edited by a moderator:

Jon_C

Established Member
Billy,

Allan meant *you* to email him and not the other way around (although I wouldn't be surprised if he responds to your post by email because he seems like a helpful guy).

You might be better editing your post to remove your email address to avoid being spammed, not necessarily by AVforums members but more likely as a result of automated spam systems adding your email address to their database.

In the meantime I have reported your post to suggest that a moderator does that for you in case you don't read this for a while.

I hope you get your problem resolved. Please do post here again if you think we can be of any help.
 

Member 518284

Distinguished Member
Thanks Allen

email sent but as Jon has said please edit your post to remove your email addy

also as a reminder, please reset to factory defaults after every fw update

Allan
 
Last edited:

The latest video from AVForums

Spielberg, Shyamalan, Aronofsky, Chazelle, Eddie Murphy and Mel Gibson - all the latest movies
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom