Onkyo TX-SR806 keeps blowing Left Rear Surround channel

hottim

Standard Member
Hi Everyone. Hopefully someone can shed some light on this matter. I have a Onyo TX-SR806 which has blown it's 3rd left rear channel in 2 years. It is hooked up to some Harmon/Kardon Surrounds, left right and Centre and Polk Floor Standing speakers for left and right. I do not use the Harmon/Kardon left and rights, but they are mounted on the wall. The previous two times I heard a loud pop from the surround speaker, and then the receiver would go into the 'protection mode' and won't switch on. I have ran the same setup with my Yamaha receiver and never had any issues. I have checked the impedance on the speakers, and all are correct. The Onkyo supplier here in South Africa made me pay for the first repair, and told me it was caused by abuse even thoug it was under warranty. I never even turn my sound up very loud, and don't play compressed music. I only watch Blu-ray and Dish. All speakers are hooked up with banana plugs, and wires are in conduits in concrete walls, never touching each other. I am very technically orientated. After the first repair, I decided to shift my room furniture 90° to the right, therefore, my Left front speaker, became my left rear surround, eliminating the possibility for a speaker or wiring causing the damage. I received the unit back, and ran the system without surrounds for a week. I hooked up the surrounds after that, and about 4 months later, another pop came from the left rear surround. I took it back in to suppliers, with my speakers, and they said that although the speakers has no faults, that Piezo tweeters can arch and cause damage. (Please let me know if this is true). They told me that they would repair it out of good faith. I had no interrupted enjoyment for about a year now, until....

This morning when I decided to switch on the receiver, a loud pop came from the left rear surround channel. Sparks flew from the bottom, with loud electrical sounds, and smoke appeared from the receiver. I immediately knew what happened. This is becoming a fire hazard, and my 5month old son, started levitating cause of the drama happening inside the Onkyo. I dread the fact to listen to their down-talking to clients, and it frustrates the living hell out of me. I do own my own business, and do not treat my customers in such a demeaning way, but this is a whole other story.

Can someone maybe let me know, why a item would keep on blowing the same channel. I have set the speaker impedence to 6 ohms, bi-amp is off, I have said the frequency to 150-200khz on instruction from the Onkyo suppliers, although my speakers can do more.

Another issue is that my Wii won't work with Component cables, and have tried 2 different ones. Only composite.

I will be taking the receiver in on Tuesday or Wednesday, and would like to know if anybody has had the same issues, what was at fault, or any recommendations.
 

The latest video from AVForums

Podcast: Trinnov Room Optimiser: A full explanation of Trinnov and its room optimiser technology
Support AVForums with Patreon

Top Bottom