Onkyo TX-SR608 - Important find

Toadus

Well-known Member
Hi fellow Onkyo owners :)

I discovered something yesterday which I thought I should share. I've always had my various HDMI inputs to my Onkyo set to 'through' mode, as I don't like any extra processing going behind my back. However, after changing TV's, I've realised that a problem I was experiencing was actually down to the amp.

When watching fast pace sports, such a football and rugby, I've noticed that players' shirts sometime smudge and ghost up to an inch from where they actually are. Interestingly, it doesn't always happen on fast pan shots. Also, I noticed grass smudge and lose its sharpness. Well, I found that this problem disappeared when turning the amp off and using the HDMI Thru function, so even though I had the source setup as 'through' and no upscaling set, the amp was still doing something to the video signal. Anyway, I found out that by setting Game mode to 'on' it stopped all video processing and made the picture just like without the amp being used, or like using the HDMI Thru function with it turned off. Fantastic.

I recorded some football and can prove this, so if I have some free time I could try to take a snap shot to prove it. Either or, it's a great little find and made me a lot happier! :)
 

mjn

Distinguished Member
Do you still get the OSD?
 

mjn

Distinguished Member
Erm....the On Screen Display :)
 

mjn

Distinguished Member

bedweljp

Standard Member
Hi fellow Onkyo owners :)

I discovered something yesterday which I thought I should share. I've always had my various HDMI inputs to my Onkyo set to 'through' mode, as I don't like any extra processing going behind my back. However, after changing TV's, I've realised that a problem I was experiencing was actually down to the amp.

When watching fast pace sports, such a football and rugby, I've noticed that players' shirts sometime smudge and ghost up to an inch from where they actually are. Interestingly, it doesn't always happen on fast pan shots. Also, I noticed grass smudge and lose its sharpness. Well, I found that this problem disappeared when turning the amp off and using the HDMI Thru function, so even though I had the source setup as 'through' and no upscaling set, the amp was still doing something to the video signal. Anyway, I found out that by setting Game mode to 'on' it stopped all video processing and made the picture just like without the amp being used, or like using the HDMI Thru function with it turned off. Fantastic.

I recorded some football and can prove this, so if I have some free time I could try to take a snap shot to prove it. Either or, it's a great little find and made me a lot happier! :)

I have had the same problem with my Sony TV on normal programmes some worse than others. I dont know what you mean by HDMI through with amp off. How do you set game mode to on?
 

Toadus

Well-known Member
Negative...

Game mode doesn't hinder the quality, and in my view, it makes the quality a lot better as it turns off the video processing from the Onkyo. I don't want the Onkyo to do anything to the picture.

Bedweljp - Within the 'setup' menu, you need to go into one of the menus which gives the options to change HDMI settings. It might be 'hardware' menu but I can't remember. You need to turn the HDMI feature on which allows communication between the Onkyo and other devices you have connected via HDMI. Now, whenever you press the standby button on the Onkyo or the remote, the Onkyo with go into Pass-through mode not standby mode. You can tell as the small LED on the Onkyo will turn amber and not red. Whatever input selection you had selected prior to pressing the power button will now be in Pass-through mode.

Game mode can be selected per individual input source. You need to go into the 'setup' menu once again and find your way to the video settings. Set Game mode to 'on' and display to 'through'. This will stop all video processing from the Onkyo. You'll also need to go into Monitor Out setting and change that to 'through' as well to stop any upscaling.
 

Toadus

Well-known Member
I remember reading that myself. I can assure you, it's not the case. It simply turns off the video processing. I started noticing strange things when watching football games, and put it down to my TV. I got a new TV and saw the same problems. I noticed that when I put the Onkyo into pass-through mode, all the issues stopped. I then found out that by enabling game mode, it gave an identical picture to pass-through. I can assure you, the picture quality with moving images is considerably better with game mode on.

I receorded some football where I saw some problems, so I could try and take some snap shots to show you what I'm referring to.
 

antg1985

Active Member
Hi, just want to say thanks for this, I have had comet out 4 times as I had a problem with my tv, the fixed part of it but still had the same problem as you, was convinced it was
My tv, now game mode had sorted it.

Just one question though, inhale the 578 which is similar to yours but I cannot get pass through mode when the amp is off, how do you do this exactly?


Thanks

Ant
 

Toadus

Well-known Member
Hi, I'm glad this sorted your problem, excellent. Without having your manual to hand, I can't tell you the answer to your question I'm afraid. Maybe worth starting a thread in the Onkyo Products section?
 

majnu

Member
what does this exactly do, what souces are connected to your amp?
 

athewitt

Active Member
I noticed the same blurring when watching champions league on wednesday - first time I had watched footie since getting the amp. I will try this out to see if it fixes it. I figured it was ITV1HD being crap but maybe not...

Tnx
Andy
 

MattW

Standard Member
Toadus, thanks for the info. Seems like a great find as I have been having the same issues with the fuzzy shirts watching football. I have changed the settings to enable gamer mode and next time the footie is on I will see what happens. I was hoping this may also fix 2 other issues I have been having;

The first is blurring when watching something quick paced that is quite dark. I had the issue when I first got the TV and SKY HD about 15 months ago, but replacing the standard HDMI lead SKY provided for a better quality one solved this issue. Since I purchased the 608, about 5 or 6 weeks ago, the blurring is back. Again, I don't know if this has fixed the issue so I will keep an eye out over the next few days.

The second isnt fixed, as I just checked. When I connect my laptop via the HDMI port, the picture is fine and so is the sound on the hole, but every minute or two I loose sound for a few seconds, the display on the 608, except the port selected 3 letters (i.e. GAM for the game port or CBL for the CBL/SAT port), goes (would normally say THX Music etc) and then comes back, like it is loosing signal but it cant be as the picture doesn't go. I've tried 3 different HDMI leads and different ports on the 608, with nothing making any difference. I can plug my laptop directly into my TV via HDMI and do not have these issues, just naturally I cant have the surround sound on, only the very poor attempt of my Samsung TV. Any ideas? :lease:
 

athewitt

Active Member
I watched some of the Liverpool/Man City game last night through Sky and having this game setting enabled seems to have cured the colour 'streaking on fast camera pans' issue for me. I have not tried it on ITV1HD yet which seems to give a lower quality picture in general, but I will do.

Thanks,
Andy
 

Toadus

Well-known Member
Toadus, thanks for the info. Seems like a great find as I have been having the same issues with the fuzzy shirts watching football. I have changed the settings to enable gamer mode and next time the footie is on I will see what happens. I was hoping this may also fix 2 other issues I have been having;

The first is blurring when watching something quick paced that is quite dark. I had the issue when I first got the TV and SKY HD about 15 months ago, but replacing the standard HDMI lead SKY provided for a better quality one solved this issue. Since I purchased the 608, about 5 or 6 weeks ago, the blurring is back. Again, I don't know if this has fixed the issue so I will keep an eye out over the next few days.

The second isnt fixed, as I just checked. When I connect my laptop via the HDMI port, the picture is fine and so is the sound on the hole, but every minute or two I loose sound for a few seconds, the display on the 608, except the port selected 3 letters (i.e. GAM for the game port or CBL for the CBL/SAT port), goes (would normally say THX Music etc) and then comes back, like it is loosing signal but it cant be as the picture doesn't go. I've tried 3 different HDMI leads and different ports on the 608, with nothing making any difference. I can plug my laptop directly into my TV via HDMI and do not have these issues, just naturally I cant have the surround sound on, only the very poor attempt of my Samsung TV. Any ideas? :lease:

Not sure if this will fix the blurring issue. Without knowing more about the problem I can't tell whether it's the amp to blame or not. If it's only blurring during dark scenes, it's not a Samsung TV you by any chance is it? ;)

About the sound dropping out: It's either your input device or the amp is faulty. There's no other reasons I can think of, sorry.
 

Toadus

Well-known Member
I watched some of the Liverpool/Man City game last night through Sky and having this game setting enabled seems to have cured the colour 'streaking on fast camera pans' issue for me. I have not tried it on ITV1HD yet which seems to give a lower quality picture in general, but I will do.

Thanks,
Andy

Sweet ;)
 

CH_Peter

Well-known Member
I did this the other day. Sorted out blurring and ghostly effects on fast pan shots. Thank you.
 

rickardl

Member
If you really want to turn off all video processing:
Press VCR/DVR and RETURN on the AV receiver at the same time.
Select "Skip" in the "VideoProcessor" setting by pressing RETURN repeatedly on the display.
To reset back to the original setting, press the same button at the same time.
 

MattW

Standard Member
Not sure if this will fix the blurring issue. Without knowing more about the problem I can't tell whether it's the amp to blame or not. If it's only blurring during dark scenes, it's not a Samsung TV you by any chance is it? ;)

About the sound dropping out: It's either your input device or the amp is faulty. There's no other reasons I can think of, sorry.

The blurring issue doesn't seem to be fixed on fast moving scenes. I will be watching the Arsenal-Liverpool game later and I will see if the colour blurring has gone. And yes, it is a Samsung TV, are they known for this?

Also regarding the sound, I e-mailed Onkyo directly. They said it was the output of my laptop, and I needed to change it to 'bitstream', and let the amp do all the processing. I didn't really know what that meant or how to do it but a few Google searches told me I needed to bypass the Windows Kernel Audio Mixer (KMixer). I tried this, but I'm not sure if I did it right and the problem was still there. So while playing around I went into the system settings on the laptop and found that the NVIDIA Control Panel that controls the sound and picture, and specifically the HDMI output, processed 44.1kHz to 48kHz, which apparently was causing the problems (according to the instructions on bypassing the Windows Kernel Audio Mixer). I also turned off everything else it did so it was a direct output. The sound problem is now solved :clap:
 

Toadus

Well-known Member
The blurring issue doesn't seem to be fixed on fast moving scenes. I will be watching the Arsenal-Liverpool game later and I will see if the colour blurring has gone. And yes, it is a Samsung TV, are they known for this?

Also regarding the sound, I e-mailed Onkyo directly. They said it was the output of my laptop, and I needed to change it to 'bitstream', and let the amp do all the processing. I didn't really know what that meant or how to do it but a few Google searches told me I needed to bypass the Windows Kernel Audio Mixer (KMixer). I tried this, but I'm not sure if I did it right and the problem was still there. So while playing around I went into the system settings on the laptop and found that the NVIDIA Control Panel that controls the sound and picture, and specifically the HDMI output, processed 44.1kHz to 48kHz, which apparently was causing the problems (according to the instructions on bypassing the Windows Kernel Audio Mixer). I also turned off everything else it did so it was a direct output. The sound problem is now solved :clap:

I had a Samsung LE40A656 for a few years. What a fantastic TV! But it suffered, like other Samsung TV's, with black smudging. It's just down to the technology Samsung used and cannot be rectified. Putting the brightness up and not using HDMI Black helps a fair bit, but that then ruins the picture. Swings and roundabouts.

Glad you got the sound sorted. Setting the audio to bitstream means that the laptop will send the audio to the amp for decoding, rather than decoding it itself. I don't have any experience with sound from a PC, but with Blu-rays as an example, it's typically better for the amp to do all the decoding rather than the player, as the amp is designed to do it and will typically do a better job.
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel

Latest News

NAD launches M23 hybrid stereo power amplifier
  • By Andy Bassett
  • Published
Microsoft to acquire Activision Blizzard for $70 billion
  • By Andy Bassett
  • Published
Cyrus Audio joins BluOS Audio Ecosystem
  • By Andy Bassett
  • Published
Audio Pro expands C10 MkII speaker range with new colours
  • By Andy Bassett
  • Published
BBC licence fee to be scrapped in 2027
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom