ONKYO TX-SR605 powers down at certain volume when watching certain Blu Ray movies

Jason565

Standard Member
My ONKYO TX-SR605 powers down when i play such movies like "The Incredible Hulk" and "Knowing" via my Sony BDP S350 player. This happens when the volume during these movies is increased (i.e. explosions etc).

Having checked the User Manual i can find no reason behind this fault.

I'm sure this a simple problem and is more than likely a user error!!

This is my first post so be gentle with me! LOL

Look forward to hearing your verdicts

Many Thanks
 

james.miller

Well-known Member
IT could be down to somethign simple like a stray strand of wire, so the first thing id do is double check all the speaker connections on the amp end and the speaker end. Have a quick look for any nick's in the speaker wires as well. If you cant find anything, it could be down to a faultly speaker which honestly is very unlikely, its more like to be a problem with the amp itself.


Let's hope it is just a stray strand!
 

Jason565

Standard Member
James, Archer,

Many thanks for the replies, i will check the cables and look at the threads you have directed me towards over the course of the weekend.

Digital,

I am driving Celestion F30's (120W Power handling).

Many thanks again and i will post a reply when i have tried out your suggestions.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom