Onkyo TX-NR787 won't pick up audio from Oppo BDP-93

MilOnTheMoon

Novice Member
My first time posting. I'm banging my head against the wall trying to figure out this problem and I hope someone can help.

Dug out my old Oppo BDP-93 primarily to listen to some SACDs/DVD-As I haven't heard in a while (now that I'm actually home). For whatever reason, via HDMI my Onkyo TX-NR787 accepts the video but not the audio for any disc format including Blu-rays. I have tried so many configurations to troubleshoot the issue including...
* swapping cables
* swapping ports
* changing HDMI output from auto to LPCM or Bitstream
* disconnecting the TV to see if it was an ARC issue
* attempting dedicating one HDMI to video and the other to audio (not sure I did this correctly)
* confirming that firmware is most recent -- it is
* factory reset

The receiver keeps looking for analog input and the PCM label on the display keeps blinking. Oppo display says multichannel.

Connected Oppo to TV to use ARC return. Only two channels will come through.

Connected Oppo to Receiver using optical. Only two channels will come through.

Connected Oppo to another receiver to test. It works, registering DSD on SACD playback.

What's up with my Onkyo? It has been absolutely fantastic so far and this is the first time I've had issue with it.
 

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom