Onkyo TX-NR609 wont boot up although EEPROM is supplied

TheMorgy

Novice Member
Hi guys

So I have this Onkyo TX-NR609 which won't start anymore.
Plugging it into the power supply, a relais clicking in ~1Hz frequency from the back of the case, so I did some research and found out that the power relais for the transformator is likely to fail, so I bridged the relais output.
Sadly this didnt help, the relais still clicking. Checking the power button resulted 3,3V, and all the fuses are fine. I also removed the old relais and replaced it with a 12V car relais, but same outcoming.
Removing the relais again, bridging the outputs and plugging in, but the receiver still won't start.
I can measure a pulsing voltage of 1-11V along the relais.
So I tried to check the relais again with 9V battery, working fine, I reattached it and rebuild the amp.
So I went to check the 5 line cable from the mainboard to the relais board. Connection is fine, also Pin 3 GND is connected well to the chassis.
Plugging the amp into power, I measured the pins of the 5 line cable.

1. POWERD pulsing 0-11V (this one triggers the relais)
2. +10VS pulsing 9-11V
3 GND connected to chassis
4. +12VD_ST pulsing 9-11V
5 pulsing 3.3-5V

Q181 is soldered well, also the 5 line cable did well for checking for resistance.
Q181 is well connected to GND, so I checked the base pin, it is pulsing 0-3,3V.
Measuring R692 resulted 219Ohms (measured between base of the transistor and R691).
Checking Pin 126 (measured at R691) is also pulsing 3,3V so I checked the supply of Q701 on easy-to-reach C505, and this is constant 3,3V.
So if I get this right, Q701 has nice and constant 3,3V, but somehow triggers Q181 and the relais by slow frequency.
Can this be a faulty EEPROM?
Or much more likely defect X501 (quartz) ?

Also. while trying to reach the relais, I removed the transformator and a white plastic washer fell out, where did it came from?

Thanks in advance
 

dobrykamil

Well-known Member
Replace R921, measure resistance of the relay's coil. Should be either 300 o 150 Ohm.
Capture.JPG
 

TheMorgy

Novice Member
Relais resistanceis about 480Ohm
But replacing with 12V didnt help

I replaced R921 but this didn't help, the old one I took out was also 46Ohm.
I tried bridging the relais and soldering a 220Ohm between the relais input to lower the resistance of the coil (and shortwired the outputs) to simulate a 220Ohm Coil Relais but this also doesn't help
 
Last edited:

dobrykamil

Well-known Member
Not sure is the R921 is dodgy, but I have fixed few Onkyo amps, like tx-nr515 where that resistor (220 Ohm) was the culprit. It would allow higher current to flow through relay's coil, eventually killing relay after a while.
Does you Onkyo powers on itself as soon as you connect it to the mains?
 

TheMorgy

Novice Member
Sorry to tell it wasn't that one ^^
Yes, the amp starts clicking immediately after plugging in
 

The latest video from AVForums

Podcast: LG C1 OLED + JBL Synthesis SDR-35 First Thoughts, plus TV Show & Disc Reviews & more
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom