Onkyo Tx-NR 696 failing Internet Service test

Morac

Novice Member
I upgraded my Onkyo TX-NR696 to the Oct 14, 2021 firmware about 2 weeks ago via the network. Today I went to use the network features and any that need to access the Internet are failing. I ran a network check and it's failing at the Internet Service test. It does this when set to used a Wired or Wireless connection. I tried powering my router and the Onkyo off and back on which didn't help. Neither did doing a factory reset. The Onkyo is responding to LAN requests since I can use the Onkyo iOS app to control it, I can AirPlay to it and I can access it's web page. I can't use Chromecast anymore since it's no longer showing up in Google Home so I can't accept the TOS there after the factory reset.

According to my router the AV isn't making any network connections at all outside my network. It doesn't even seem to be trying.

Basically any Net feature that requires Internet access no longer works. I figured I'd try to download the firmware and see if I could update again or maybe find the prior firmware, but the download.onkyo.com doesn't exist.

Basically I'm stuck and don't know how to fix this. Any ideas?

Edit:

Is Onkyo just gone? The entire http://onkyo.com web site doesn't exist anymore. It's not that it's just down, it doesn't even have an IP address. It's basically just gone from the Internet. It looks like Onkyo was acquired by Voxx back in June. Did they shutter Onkyo?

The only connection I see being attempted by the Onkyo is to a variety of AWS IP addresses which immediately close.

Is that why my Onkyo thinks there's no Internet? That would be a horrible design if none of the network features work if an AWS hosted server isn’t available.
 
Last edited:

dobrykamil

Well-known Member
Onkyo TX-NR696
Version: R117-0606-1130-0028
Release Date: 8/4/2020
Download

Good luck.
 

dobrykamil

Well-known Member
Forgot to say, you need to do USB -> ALL: ALL firmware update type.
 

Attachments

  • Screenshot 2021-11-03 at 10.19.42.png
    Screenshot 2021-11-03 at 10.19.42.png
    466.6 KB · Views: 52

Morac

Novice Member
Can just the NET firmware be reinstalled?
Is that the US version of the firmware?

I still don’t know why no NET services that connect to the Internet are working or why the AVR thinks there’s no Internet access. The only outbound connection attempt is to a range of IP addresses in the Amazon AWS cloud, but they all immediately close. I don’t know why that would stop things like Tidal or Tune-in to not work (or even try to connect).

I know Onkyo.com is down, but I would hope that wouldn’t break NET features. I’m assuming it’s still working for others.
 
Last edited:

Cafedelmar

Novice Member
Ah, I woke up today to find my TX-NR575E "Net" facilities also defunct. "Internet Service Test" Failed to connect and I've done wired and Wi-Fi connections to no avail. I too have found the Onkyo web presence absent. Fantastic. A facility I used every day, several times a day.
 

Morac

Novice Member
Ah, I woke up today to find my TX-NR575E "Net" facilities also defunct. "Internet Service Test" Failed to connect and I've done wired and Wi-Fi connections to no avail. I too have found the Onkyo web presence absent. Fantastic. A facility I used every day, several times a day.

Well at least I know my NR696 isn’t broken, but who designs it such that the Onkyo web site needs to be working for all the Music service features to work? That’s ridiculous.
 

Cafedelmar

Novice Member
Well at least I know my NR696 isn’t broken, but who designs it such that the Onkyo web site needs to be working for all the Music service features to work? That’s ridiculous.
I agree most wholeheartedly! The internet radio I used to use in my workshop went the same way. The original company stopped supporting (curating?) the web content and there was no way to direct the box to look at the real source addresses. Door stop now.
 

SavedMen

Novice Member
My Pioneer VSX-832 also doesnt work today - and the european Pioneer website is also down. If I try a connection test from the receiver, I can see in my network log, that it tries to connect to ;
2021-11-03 14_12_47-Pi-hole - 44f3fbf87fd9 og 26 flere sider - Arbejde - Microsoft Edge.png

But doest receive a response, and probably therefore assumes, that it is offline.
I sure hope they get this fixed, or else its worthless.
 

Cafedelmar

Novice Member
My Pioneer VSX-832 also doesnt work today - and the european Pioneer website is also down. If I try a connection test from the receiver, I can see in my network log, that it tries to connect to ;
View attachment 1596826
But doest receive a response, and probably therefore assumes, that it is offline.
I suspect the forum may light up with similar comments today then....
 

dobrykamil

Well-known Member
Can just the NET firmware be reinstalled?
Is that the US version of the firmware?

I still don’t know why no NET services that connect to the Internet are working or why the AVR thinks there’s no Internet access. The only outbound connection attempt is to a range of IP addresses in the Amazon AWS cloud, but they all immediately close. I don’t know why that would stop things like Tidal or Tune-in to not work (or even try to connect).

I know Onkyo.com is down, but I would hope that wouldn’t break NET features. I’m assuming it’s still working for others.
It’s a EU version and above metod allows you to reinstall fw over current one.
 

Morac

Novice Member
Got a response from Onkyo support:

“We are aware of the issue and are working a solution.”

So I’m guessing it’s a server problem (Onkyo.com disappearing was a red flag). Really dumb design that an Onkyo server issue knocks out all NET functionality.

On a side note, the email response came from Home - 11 Trading Company. I don’t know how they are related to Onkyo, but they seem to be handling support.
 
Last edited:

Morac

Novice Member
Is there a file for the TX-NR575E?

Don’t bother re-installing the firmware. It’s not a firmware issue.

Well arguably it is since the network code apparently thinks the Internet is down if Onkyo is down, but uploading the firmware again won’t fix that.
 
Got a response from Onkyo support:

“We are aware of the issue and are working a solution.”

So I’m guessing it’s a server problem (Onkyo.com disappearing was a red flag). Really dumb design that an Onkyo server issue knocks out all NET functionality.

On a side note, the email response came from Home - 11 Trading Company. I don’t know how they are related to Onkyo, but they seem to be handling support.
Same issue with TX NR787 here in Buenos Aires, Argentina. Unbelievable that a server issue turn down all NET functionality.
 
Update from Onlyo Support

"Hello, We are aware of the current situation and are actively working towards a solution. In the short term may I please suggest using Bluetooth, audio from a device that s directly connected to the unit via HDMI, RCA Analog, Digitla Optical, or Digital Coaxial. May I please ask if the Receiver is connected via Hardwired or via Wi-Fi. Have you attempted to use Airplay, Chrome-Cast, or Spotify Connect if you have an premium Spotify account."
 

Cafedelmar

Novice Member
Well let's hope a resolution is forthcoming soon. Imagine Tesla cars failing to charge because Elon was locked out of his office.... :eek:)
 

Sonicchild86

Novice Member
Thank god for that! I’ve been going nuts with it for the past day so I’m glad to hear I’m not the only one… on a similar note, I have the Onkyo txl20d and I am on my second unit due to airplay and bluetooth issues (kept cutting out on airplay and then would connect to both airplay and bluetooth but no sound would come through). The replacement hasn’t cut out really on airplay but has stopped working (like before connects but no sound) a few times and only unplugging has resolved the issue. Can I ask has anyone else had issues with their bluetooth or airplay intermittently not working? Would be great to hear off someone as I really like the unit but it’s annoying it doesn’t always work with airplay and bluetooth.
 

GULAM9890

Novice Member
Great just tested mine back to normal. Thank you all for all the information and feedback appreciate.
 

soest009

Novice Member
Unfortunately here (Netherlands) still no dice using a TX-NR555.
Internet service test keeps failing and no internet radio services available.
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel

Latest News

NAD launches M23 hybrid stereo power amplifier
  • By Andy Bassett
  • Published
Microsoft to acquire Activision Blizzard for $70 billion
  • By Andy Bassett
  • Published
Cyrus Audio joins BluOS Audio Ecosystem
  • By Andy Bassett
  • Published
Audio Pro expands C10 MkII speaker range with new colours
  • By Andy Bassett
  • Published
BBC licence fee to be scrapped in 2027
  • By Andy Bassett
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom