Onkyo Receiver stopped getting ARC signal from TV

Mascheroni

Novice Member
Hi folks!
After 4 years of regular use, all of a sudden my Onkyo Receiver HT-R494 simply stopped receiving ARC signal from my Samsung TV. The only way I can get audio is through Optical Cable, but I lost ATMOS , True HD/DTS Master capability...and also ARC TV volume/power controls.
When I select TV audio - Receiver...it keeps loading for some 10 seconds and TV returs the message: could not connect device.

Tried tons of troubleshooting steps...
TV factory reset, switch cables, receiver factory reset, hdmi refresh (unplug all cables and wait 10 minutes), TV software update, all basic stuff like switching Anynet CEC on and off....you name it.

Is is possible that I have a hardware issue on my receiver TVOut HDMI port? A power surge could have damaged it? Is there a way to test TVOut port functionality?
I'm afraid that I replace my receiver and this is not the root cause.
 

Mark.Yudkin

Distinguished Member
The AVR (or TV) may well be defective. Can you take your HT-R494 to a friend's place to test if his TV can talk to it? Or to your dealer for a quick check? That way you'd know if it is or isn't faulty.
 

Mascheroni

Novice Member
The AVR (or TV) may well be defective. Can you take your HT-R494 to a friend's place to test if his TV can talk to it? Or to your dealer for a quick check? That way you'd know if it is or isn't faulty.
Tried this yesterday and issue persists. Pretty sure its a defective HDMI board, just like so many others from Onkyo brand. Unfortunetely, with the company restructuring in 2020 we do not have support in Brazil and repair shops claim parts are not available and would take several months to arrive...prices are not cheap either so I'll have to either live with a donwgraded AV or purchase a new one, from a decent and financialy healthy brand this time.
 

DavidT

Well-known Member
Could be an issue with the TV. I have a Samsung TV that for some reason lost the ability to work with a Sony bluray player. The BR player used to work ok with the TV and it works with any other TV in the house just not with the Samsung.
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom