Onkyo not processing dts?

Discussion in 'AV Receivers & Amplifiers' started by Duckers, Jan 19, 2008.

Tags:
  1. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I'm still somewhat new to the audio visual scene. I started watching Alien tonight, hoping for a good scare with the new surround sounds set up. I'm using a PS3 to play the DVD, via HDMI connected to my Onkyo 605.

    What I don't understand is why the DTS track on Alien is not playing correctly. All I'm hearing is the same sound played from the rear, and rear left and rights, while the majority of the sound stage is coming from the front speakers. I'm not hearing any surround at all.

    This is probably because I just don't have the correct settings. I set the PS3 to output in bitstream, because this sends the audio to the receiver to decode, right? Then on the receiver I hit the 'Surround' button so that the DTS Neo:6 Cinema sound option is selected. Am I right in thinking I want the PS3 set to bitstream for normal dolby and dts sound, and LPCM for high definition? I'm just a bit confused about LPCM/Bitstream, need to do a bit of reading on it.

    I know this has probably been asked all the time but couldn't find anything in the search about the Onkyo 605 and DTS tracks.
     
  2. MarkTaylor

    MarkTaylor
    Well-known Member

    Joined:
    Feb 28, 2002
    Messages:
    4,328
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    133
    Ratings:
    +662
    Neo6 is a pseudo surround mode and if your amp was getting the DTS stream it would automatically switch to DTS mode.

    On the PS3 have you told it that it can send DTS out?

    I seem to recall there is a menu where you indicate the formats that it is allowed to output.
     
  3. davepuma

    davepuma
    Distinguished Member

    Joined:
    Jun 24, 2004
    Messages:
    17,536
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +3,506
    DTS:Neo6 is not true DTS. It's a matrix decoder that takes a 2.0 channel stereo and mixes it to output up to 6 channels. It's similar to Dolby Pro Logic 2. Did you actually select the DTS soundtrack on the disc? Usually this is done at the menu of the movie at the start or once the movie has started by cycling through the audio soundtracks by pressing the audio button. Check your ps3 audio settings as well though.
     
  4. lowmans100

    lowmans100
    Well-known Member

    Joined:
    Dec 20, 2006
    Messages:
    1,480
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Ratings:
    +461
    I don't know about the Onkyo's but on my amp for the audio input selection I just set it to auto then whatever signal it recieves from the source it recogises the sound format and decodes it accordingly. The only time I ever touch the audio selector is when I want the amp to do clever things with a stereo (2ch) input.
     
  5. chic

    chic
    Well-known Member

    Joined:
    Jul 1, 2001
    Messages:
    5,985
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    glasgow
    Ratings:
    +871


    yes the best setting for the ps3 and dvds is bitstream over hdmi, then it sends the audio for the amp to decode, if your amp is set up correctly and you select dts on aliens you should get a dts 5.1 track, for blurayys it needs to be set as pcm so you can get the hd audio.
     
  6. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Thanks for all the replies.

    I've set the PS3 to bitstream, and in the Onkyo menu, I've set the listening presets for the source (DVD) to the corrosponding mode, so for DTS, I've set it to DTS, and for Dolby, I've set it to Dolby.

    I'm getting nothing from the rears at all now. I've switched all the components off and on, and not touched any of the listening mode buttons, but the receiver doesn't click to the right audio channel. Is there a way to set it to select the right audio decoder automatically? Is there some way to reset it and see if that might be a problem?
     
  7. 6950rpm

    6950rpm
    Active Member

    Joined:
    May 26, 2006
    Messages:
    149
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +10
    You haven't saidd if you have checked the PS3's settings and specifically put a tick next to all of the Audio options over HDMI.

    I believe that is were your problem lies.
     
  8. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Ah, I'd always selected auto on the sound config, and tried manual and theres all the codecs to choose from! I've enabled DD and DTS, do I need to enable any of the LPCM ones, there are a lot and I'm not 100% sure.

    Playing Alien now with the DTS track selected, receiver clicks and shows it is playing the DTS track, but nothing from the rear speakers still :(

    Time for bed for me, I'll pick this up tomorrow, getting tired and frustrated now :p
     
  9. Rom

    Rom
    Well-known Member

    Joined:
    Aug 16, 2007
    Messages:
    2,064
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    116
    Location:
    Sheffield
    Ratings:
    +746
    2 things to note:

    If you set the PS3 to bitstream then you cannot get any HD audio out of the console, it will downmix.

    If you have the HDMI Audio out on the amp set to YES, the amp will downmix the audio. I had this confirmed from Onkyo as I had a moan at them about it. Turn audio out to NO. You won't get sound from the TV (turn it back on when you want it), but the amp won't downmix.

    If you are not botheresd about the amp decoding the audio, let the PS3 do it and you can have all formats.

    Select the sound setup, select HDMI, select auto. Make sure all formats are displayed (DD, DTS and lots of PCM up to 7.1).

    Then go into BD/DVD settings and set audio out to PCM.

    This means that you won't see DD/DTS on the amp, you will see 'Multich'. But you will get the full effect (if you have turned the audio out to NO).
     
  10. 6950rpm

    6950rpm
    Active Member

    Joined:
    May 26, 2006
    Messages:
    149
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +10
    Almost!

    If you select Bitstream on the PS3 and then select a PCM audio track on a BD, it will output it as PCM and not Bitstream.
     
  11. Rom

    Rom
    Well-known Member

    Joined:
    Aug 16, 2007
    Messages:
    2,064
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    116
    Location:
    Sheffield
    Ratings:
    +746
    I said HD audio, meaning the new codecs, DTS HD/MA and DolbyTHD/DD+

    PCM has been around for years! :D

    PCM will also always be output whether PCM or bitstream is selected. You will only get 2ch PCM if HDMI Audio out is set to YES though.
     
  12. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Thanks for the help but the problem doesn't seem to be the settings.

    As I said I'm not getting any sound from the rears at all. I've tried all the combination of settings mentioned; HDMI Audio Off on the receiver, all correct sound settings on the PS3, and tried both bitstream and PCM. Bitstream shows the correct sound on the receiver (DTS or Dolby), or shows Multich when PCM is selected, but no go either way.

    I've tried the Dolby and DTS tracks on Alien and the Dolby track on Transformers. I get some awesome sound from the left, right, centre and sub, but nothing from the rear left, right and backs.

    I know the speakers are working and connected correctly, I can get sound through them with other things. I've watched Hi-Def Planet Earth recorded from BBC HD, that had a good surround track that played correctly.

    Do you think I should try doing the Audyssey setup again?
     
  13. Rom

    Rom
    Well-known Member

    Joined:
    Aug 16, 2007
    Messages:
    2,064
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    116
    Location:
    Sheffield
    Ratings:
    +746
    you ae positive you have your surrounds in the 'Surr Speakers' posts on the back and not the 'Surr back speakers' posts?
     
  14. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I have a 7.1 setup, and each speakers plays the test sound from the correct speaker.
     
  15. Rom

    Rom
    Well-known Member

    Joined:
    Aug 16, 2007
    Messages:
    2,064
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    116
    Location:
    Sheffield
    Ratings:
    +746
    Okies, just checking :D TBH I'm a bit stumped now :confused:
     
  16. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I could understand if I wasn't getting any sort of surround sound, but I've just tried a couple of demo's on the PS3 and they all played the surround sound track fine. I also tried the Xbox 360, which is connected by Optical, and that plays the DD Extra track perfectly.

    This doesn't make sense as to why the DVD surround tracks are not playing. It isn't a setup problem as it works with other sources, which means it must be something to do with the settings. I could understand if it was only Alien that didn't play back correctly, but Transformers didn't either. I'll some other DVDs in a little while and have a play around.

    Any more suggestions are welcome.
     
  17. jon1

    jon1
    Active Member

    Joined:
    Feb 4, 2006
    Messages:
    1,976
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    out in the sticks
    Ratings:
    +170


    Try setting the bd/audio ouput format(HDMI) to linear pcm




    jon
     
  18. Rom

    Rom
    Well-known Member

    Joined:
    Aug 16, 2007
    Messages:
    2,064
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    116
    Location:
    Sheffield
    Ratings:
    +746
    The only other thing I can think of is that you have it processing the signal afterwards. Whilst playing try cycling through the different listening modes on the remote (pressing the right arrow near the bottom).

    You can force the processing off in the setup menu - listening mode preset. Normally this is set by default to 'Last Valid'. Try changing the DTS one to DTS and DD to Dolby Digital. This will force the amp to default to these playback modes with no processing when that source is selected.

    Trying to think 'outside the box' :D
     
  19. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Right, having the PS3 set to Bitstream and Linear PCM gives me the same thing.

    The Rear Left and Right speakers are giving sound out, but it so quiet that I just hadn't noticed. As for the Rear Back Left and Right, they are not outputing anything still. Is this right because the DTS track is only 5.1? Even so, shouldn't the sound be coming from the Rear Backs on a 5.1 track the Rear to the side of the sofa? Mayne I have connected them up wrong :D lol
     
  20. jon1

    jon1
    Active Member

    Joined:
    Feb 4, 2006
    Messages:
    1,976
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    out in the sticks
    Ratings:
    +170

    OOOOdear:blush::D


    jon
     
  21. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I take it that the oh dear means I have connected them up wrong :D

    I wouldn't of thought I had though because the sound tests play the test tone correctly for each speaker.
     
  22. jon1

    jon1
    Active Member

    Joined:
    Feb 4, 2006
    Messages:
    1,976
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    out in the sticks
    Ratings:
    +170


    Have you ever drop kicked a amp before?:D


    Jon
     
  23. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    You're somewhat confusing me, are you saying I've broken it. I connected it up a few days back and the Audyssey setup went fine and played from all the speakers at the right points so I don't think I've connected it wrong.
     
  24. jon1

    jon1
    Active Member

    Joined:
    Feb 4, 2006
    Messages:
    1,976
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    out in the sticks
    Ratings:
    +170


    No.... when things are not going right ..it is just a saying



    jon
     
  25. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    They are definatly set up correctly. I've just switched the Surround Back Left speaker, with the Surround Left speaker, and the test tone is reporting them as switched around, so it was right.

    I've gone off the onkyo quick setup guide for the speakers, with the surround left and right as the ones being left and right of the sofa. The surround backs are positioned directly behind the sofa.

    I am right in saying that a 5.1 track should have the sound played through the rears, not the left and rights?
     
  26. MarkTaylor

    MarkTaylor
    Well-known Member

    Joined:
    Feb 28, 2002
    Messages:
    4,328
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    133
    Ratings:
    +662
    No, 5.1 should use the surround left and right, not the back left and right.
     
  27. Duckers

    Duckers
    Standard Member

    Joined:
    Oct 8, 2007
    Messages:
    30
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Thanks Mark. I've got it all setup correctly then. I'm going to try the Audyssey test again, and see if that makes any improvements. Games are very impressive, but DVD so far is poor. This will probably just require some tweaking. As I said Alien DTS plays from the Surround Left and Right, but it's quiet and doesn't sound like it is surround. I'll maybe position the speakers slightly further back.
     

Share This Page

Loading...