Onkyo 674 - purple tint from SKY+HD box - help

Discussion in 'AV Receivers & Amplifiers' started by Ric_A, May 14, 2016.

  1. Ric_A

    Ric_A
    Standard Member

    Joined:
    Nov 22, 2006
    Messages:
    42
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    9
    Location:
    Harrogate
    Ratings:
    +0
    Hi

    I'm after some help.

    I have an Onkyo TX SR674 receiver, purchased just over 9 years ago. It has done me sterling service.
    However, we have had our house refurbished, so all my AV kit was packed away for a couple of months, and on unpacking I now have a problem:

    My SKY+HD box, when connected through my Onkyo receiver via HDMI, produces an image with a purple tint across the whole screen.
    My PS3 connection is fine when connected through my Onkyo receiver via HDMI.

    I have switched both the PS3 and SKY+box over to use the other HDMI inputs on the receiver.
    I have also switched the cables over, and tried a third cable, with consistent results.

    If I plug the SKY+HD box straight into my TV, without using the receiver, there is no purple tint. However, this means I'm not taking any sound into the receiver. I am not keen to do this (even with an optical cable), as my TV only has one HDMI input, so would have to constantly change the cables over to switch between SKY+HD and PS3.

    Has anyone else experienced this, or got any tips?
    Thanks,
    Ric
     
  2. fxv300

    fxv300
    Active Member

    Joined:
    Oct 14, 2015
    Messages:
    395
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    32
    Location:
    UK
    Ratings:
    +36
    HDMI has many Data channels and if one of the channel's circuitry is not working properly you may be missing colours (simila to a VGA cable which carried GBR signals). If you tried different cables try different inputs on the AV to see if the problem is your AV.

    Be interesting to follow this topic.
     
  3. Ric_A

    Ric_A
    Standard Member

    Joined:
    Nov 22, 2006
    Messages:
    42
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    9
    Location:
    Harrogate
    Ratings:
    +0
    Yes, tried different cables, and different HDMI input ports on the receiver (PS3 works fine in either, SKY+ box not in either). Sound is fine, just the purple tint issue from the SKY+box.
     
  4. Rodders53

    Rodders53
    Well-known Member

    Joined:
    Dec 8, 2007
    Messages:
    5,126
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Bedford
    Ratings:
    +918
    HDMI handshake issue... does switching input away from Sky box to another input and back help? (It should force the AVR and sky box to renegotiate)

    I have a small TV that does similar purple screen on any HDMI source but an AV input switch fixes it.

    May also be worth checking the Sky box video output format is supported by the amp?
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice