• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Onkyo 606, weird behaviour, selective fault?

EIwood

Standard Member
I think I'm having the issues associated with the Onkyo 606's death. Hdmi handshake issues. Only, it only occurs for the PS3 and 360. My Sky HD box works fine every time, which is where the oddity starts.

I tried different cables, still the same result, and I tried plugging the ps3/360 straight into the tv, both worked fine, so the onkyo is causing the handshake issues.

However, I then switched the cables around. I plugged the sky box into the socket on the onkyo where the 360 is normally plugged in, and vice versa. Still, the 360 had the fault but the sky box was fine.

So by that logic it's not the sockets on the back of the box at fault, but just an issue with the two devices connecting? Would a firmware update fix this or is it still a serious fault? I just can't see it being a hardware failure if all the sockets work fine with one device, but not others!

It really is baffling that two out of three devices fail to handshake properly on start up, and occasionally during use. It seems the fault does and doesn't exist!

To add to the oddity, after using the onkyo for about an hour, and switching to the PS3 or 360 and turning them on, they'l connect fine, no issues. How can the device being warmer help a HDMI handshake work?

So to recap, the sky box works fine in all hdmi sockets, and the 360 fails in all sockets. Yet the 360 and ps3 both work fine once the onkyo has warmed up?
 
Last edited:

vader100

Well-known Member
I had the same over 2-3 months. After a while the sky is affected. Get it fixed,especially if you have warranty.
 

EIwood

Standard Member
Not under warranty anymore. Odd thing is it's done the same thing for at least five or six month's, only in the last few days has it gotten worse. Still doesn't affect sky though.
 

vader100

Well-known Member
Mine steadily got worse over a period of months until it was taking 10 minutes warm up time to display a picture on PS3 and a little less for Sky. Mine was 2-3 months out of warranty but still got repaired for free.
 

vader100

Well-known Member
Mine has been absolutely fine but ask me again in another 10 months or so.
 

vader100

Well-known Member
September
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom