Onkyo 507 Assigning Question

Ian Mc

Standard Member
Have the Onkyo 507.. The only cable i going to the TV it is a HDMI frm the HDMI out on the back..

I want to put my Wii through the onkyo, the wii only has
composite cables (yellow - Video, red & white - audio)
how can i plug the wii into the onkyo and can i assign the video (composite in) to the hdmi out??
or is there any way that i can so this... thanks....:lease:
 
Last edited:

paddy01

Active Member
Afraid not. The 507 isn't capable to turning an analogue video signal i.e component from the wii, to a digital signal to pass over HDMI.

I believe receivers higher in the range can do this.

In order to pass the Wii through your 507 you'll also need a component video cable to the TV from the amp's appropriate output.

Cheers

Paddy
 

Ian Mc

Standard Member
Thanks Paddy....

Is it possible to plug the composite video into one of the component
video ins and assign it that way to the hdmi?

thanks again...
 
No, component and composite only share one thing I'm afraid and that's they both start with "C".

I would buy the component accessory for the WII and run the component video direct to the TV and the red and white audio cables into the amp.

Thanks Paddy....

Is it possible to plug the composite video into one of the component
video ins and assign it that way to the hdmi?

thanks again...
 

Ian Mc

Standard Member
thanks mate... ah so there is a component cable for the wii... if i use that
to go in the onkyo component IN, i think the component section is assignable?? ie can i then asign the component to the hdmi out?

thanks again
 

dwhite

Distinguished Member
No as you have already been told, the 507 will not convert the analog video input from the Wii (or anything else) to HDMI output. No matter how you try to connect it and assign it, it won't work, because it doesn't have the capability to do it. You need an amp with video upconversion to do what you want.

Assigning inputs in the amp is not to set what output it will use, but what selection it will use. I.e if you assign component 1 to TV/Game, you have to select TV/Game to view that input.
 
Last edited:

Michaelsowa

Standard Member
Hi. I have a 606 amp and have successfully mapped both composite. Svideo and component to the one hdmi output. Is this because this amp has upscaling and so this can be acheived?
 

logiciel

Moderator
Yes, it's standard, but I didn't know the 606 had a S-Video onput.
 

Daz1969

Active Member
we used the standard lead that came with the wii - just split off the video and send it straight to the tv with audio going to the amp
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom