• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

On Demand Problems

ollymoran

Standard Member
Hi,

I have had an on-going problem of my wireless connector dis-connecting from my broadband for a while now. I decided to contact sky and ask if they could send me a new connector as I think it is this that is the problem. They have refused to send as they keep on saying its my Broadband that is at fault! My connection never disconnects anywhere else and its only sky I have the connection problem with. I also have fibre optic BT and their wireless connection is excellent. I can get it back by re-booting the box and re-booting the connector but then after a few hours goes again and this is getting worse. When I spoke to sky they got me to do a planner re-build. What the heck this has to do with the wireless connection I do not no but an hour later connection was gone again. I am getting fed up with re-booting this and that every few hours and sky won't listen to me when I say its not my broadband. As I write this my connection has gone and it says Connection to Broadband Router : ok, Connection to On Demand : Fail. and the signal strength is nearly a full bar.
What can I do to sort this out?
 

logiciel

Moderator
Get Sky to replace the connector - you can't have had it long and it doesn't work properly.
 

logiciel

Moderator
Polite Persistence Pays.
One or two agents say No, another says Yes.
 

holiday

Established Member
I have the same problem. Inform them that you have the faulty plug. They will certainly give you a new one.
 

thecatsmum

Novice Member
I've had this issue since returning to Sky. I have an older +HD box without WiFi that we connect with an ethernet cable. We had to reboot our modem, and after that, the Sky box said BB was connected, but there was a fail connecting to On Demand services. I went to the Sky website and saw it was happening to others. What worked for me was options>customise>enable on demand downloads off>save settings>enable on demand downloads on>save settings. We have to do it every time we get a new IP address.

The only things that have changed since we left are the software update and that we no longer have Sky as our ISP. I wonder if the people who are having problems with this all have some other provider than Sky, and it's some validation issue.
 

ollymoran

Standard Member
I've had this issue since returning to Sky. I have an older +HD box without WiFi that we connect with an ethernet cable. We had to reboot our modem, and after that, the Sky box said BB was connected, but there was a fail connecting to On Demand services. I went to the Sky website and saw it was happening to others. What worked for me was options>customise>enable on demand downloads off>save settings>enable on demand downloads on>save settings. We have to do it every time we get a new IP address.

The only things that have changed since we left are the software update and that we no longer have Sky as our ISP. I wonder if the people who are having problems with this all have some other provider than Sky, and it's some validation issue.

I have another provider BT infinity fibre optic, so I have a reasonably good connection so I know its not that that SKY keep telling me and refuse to send me a connector after asking them four times. I am with sky protect as insurance for my equipment so I thought sod it and emailed them and had a reply of "No problem, will be a new one with you within 3-5 working days" Its handy to have Sky protect, as people say, oh sky will just replace it. Obviously not.
 

logiciel

Moderator
You have insurance but didn't use it from the start?
They would have given you it eventually though.
 

ollymoran

Standard Member
Just don't look at what it costs you... :D
I know, it's convenience really. Rather than argue with sky all the time and time again over certain things I need replacing, they keep blaming me saying it's my fault asking and asking and getting to the point I just wanna hit someone, one quick email to sky protect and it's in the post. Sky don't give me anything they never have done and I have asked loads and loads of times. Have had 2 brand new remotes a new box and now a wireless connector.
 

kevkbuk

Distinguished Member
But what a price to for it.. Sky will fix any box/dish issues for a standard £65ish call out if you can't get it discounted or free, and the remotes and wireless connectors are cheap.
 

Steve N

Distinguished Member
I've had this too and I've got fibre optic.
I've been into the settings menu and it shows good signal but bad connection.
Usually it starts operating again after a few hours.
 

Steve N

Distinguished Member
Try doing what I described next time, Steve N. It will likely be a quicker fix.
options>customise>enable on demand downloads off>save settings>enable on demand downloads on>save settings
Must have inadvertantly skipped past your post.
Will definitely give that a go next time :smashin:
 

stewjoy

Prominent Member
Must have inadvertantly skipped past your post.
Will definitely give that a go next time :smashin:
Hi.
Did you have a go at what was suggested , I did but no luck. By the way this has only happened to me since I went BT infinity. Never had an issue with ordinary broadband .
 

Steve N

Distinguished Member
Hi.Did you have a go at what was suggested
... this has only happened to me since I went BT infinity....
My On-Demand has been behaving since I last posted.

I've got BT infinity too but got it prior to getting On-Demand so no experience with it with ordinary broadband.
Disappointing that the fix suggested by thecatsmum didn't work for you.
 

stewjoy

Prominent Member
My On-Demand has been behaving since I last posted.

I've got BT infinity too but got it prior to getting On-Demand so no experience with it with ordinary broadband.
Disappointing that the fix suggested by thecatsmum didn't work for you.
Hi.
Been onto sky went through all the usual tests still did not work. They are going to send me a new connection box. Happy.
 

ollymoran

Standard Member
Contacted Sky loads of times for getting my connector working but they STILL refused to send me out a new free connector! Everytime I ask for something free and that I need replacing they never do it, think they don't like me! Anyway Fired off a quick email to Sky Protect and within a few days I received a brand new connector and guess what??? Since then have had NO connection problems!
 

The latest video from AVForums

CES 2023 Round Up: New TV Lineups for 2023 from LG, Samsung, Panasonic, Hisense & TCL
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom