Quantcast

OLED Firmware - BBC Iplayer No Sound

Perm0115

Standard Member
Hi,
very much want to get a Philips TV however on reading the recent reviews I am concerned that there is a known fault where audio does not work with BBC iPlayer and some other timing issues with Netflix.

How often do Philips issue firmware and can any owners confirm if this issue has been fixed?

Thanks
Perm
 

drk

Novice Member
Where did you read the issue with BBC iPlayer? I have Philips 65OLED934, I have lost audio on iPlayer. I once managed to restore toggling between TV Speakers/HDMI Sound. After enabling sub out I have lost all sound again in iPlayer and cannot restore.
 

fleming222

Novice Member
I have a 50PUS8204 with this issue. The workaround I've found is to press the green button while watching a live BBC channel which restarts the current program in iPlayer but with working sound; you can then navigate back to the iPlayer home page and everything works.
I've not noticed any issues with netflix.
 

jackr80

Novice Member
I also have a 50PUS8204 purchased last week with the same issue, and no workaround seems to work. Other apps work fine.
 

rsescorts

Novice Member
I have the same issue of no sound on bbc Iplayer.
All other apps work fine. Just the BBC Iplayer, if I use the fire stick I player works fine. Its got to be an issue with the Philips TVs. Of forgot to add mines not an oled either but a 58” 7304 series
 

deebo

Active Member
I've just had the 50PUS8804 delivered and it also has the BBC iPlayer sound fault.
 

Perm0115

Standard Member
Come on Philips.... your reputation is taking in kicking for selling a product with a major fault.....
Can not imagine how it must feel to spend £1000s on a TV and then to have no sound from a key catch up service like the BBC.

Will not even consider purchasing until the new firmware is out.
 

Benanderson129

Novice Member
I am having the same issue
I have a 50PUS8204 with this issue. The workaround I've found is to press the green button while watching a live BBC channel which restarts the current program in iPlayer but with working sound; you can then navigate back to the iPlayer home page and everything works.
I've not noticed any issues with netflix.
This also works for me. Weird.

I had to factory reset the TV to get iPlayer back
 

fleming222

Novice Member
Response from Philips:
We would like to inform that this issue is currently under investigation by our technical department. We have an information that it will be fixed by the new software which is currently in a testing phase.
 

Similar threads

Trending threads

Top Bottom