OLED 55CX Fault

AirwavesN

Member
Been really happy with my CX 55 inch and PS5 setup for around six months and then everything came crashing down.

I have a feeling this is quite severe and probably won't get resolved but I'll throw it out there and see what you guys make of it.

I've been playing Spiderman for PS5 for about ten hours spread across a week or so and everything has been fine. However I was playing one afternoon when a popping sound was heard in the general area of the TV. I can't be sure if it was from the external amp and speakers or the actual TV though. The screen then goes blank but the TV remains on. I turned the PS5 off and noticed the white light was still on so hopefully that's fine.

There was a delay but with the remote I managed to turn the TV off eventually. Trying it after a minute or so, it came on and activated the PS5 along with it, but only lasted a second before popping and going off once more.

I unplugged the PS5 to activate standard TV but was met with blue, red, and green horizontal lines and nothing else. Left it for longer to try it after a further cooling off period to just hear a high pitched feedback signal but no picture. This time the amp was turned off so this was definitely coming from the TV.

This issue has since been resolved with a replacement but I'm curious to find out if anyone knows what this could have been? The problem is that it's severely effected the use of the new TV and I've become anxious about playing anything.
 

JayCee

Distinguished Member
Your old TV had a fault.
This was not caused by you gaming on it.
Relax and enjoy using it.
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom