1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Odd problem with speaker cutting out on Denon amp

Discussion in 'AV Receivers & Amplifiers' started by hangleton, Oct 9, 2004.

Tags:
  1. hangleton

    hangleton
    Standard Member

    Joined:
    Dec 16, 2002
    Messages:
    13
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello,

    I'm a bit of a novice in this game, so please excuse me if I'm missing something obvious.

    I have a Denon 1803 Amp.

    Occasionally, one speaker cuts out - the right rear. Of course I never know immediately when this happens, so I couldn't say whether anything in particular triggers it. I suspect that it doesn't actually happen during playing, but simply fails to work from the power on state.

    The resolution is simple, however. All I have to do is touch one or two of the audio cables on the rear of the amp - The sound then returns to that speaker. Until the next occurrence, when I repeat the process.

    Does anybody know what he cause of this could be?

    My intuition tells me it may be an earthing or shielding problem of some kind - I'm willing to admit that the audio cables are not the best quality and I should probably upgrade them anyway - but any possible explanation as to how this can cause a problem with just that one speaker would be much appreciated.

    Thanks in advance,

    Andy
     
  2. recruit

    recruit
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi,

    It does sound like there is a problem with your cableing and if i was you i would remove it and check it for any damage and if so change the cableing for that particular speaker before anything else.
    You could potentially damge your amp or speaker by letting the problem persist.

    John :)
     

Share This Page

Loading...