Quantcast

NVIDIA SHIELD Android TV Owners Thread

Robothamster

Distinguished Member
Hi mate there is usually a black screen with green text listing everything in the Update, this usually shows on the reboot after its completed, if the colour space fix was included then it would have been listed
Yeah it did that, cheers.

Full list of fixes are:

Bug Fixes/Enhancements: Video/Display
-Resolves issues detecting Dolby Vision TVs that also support HDR10+
-Resolves brightness issue on TVs that support Dolby Vision and HDR10+
-Resolves cast playback issues when switching between HDR and SDR content
-Fixes bug where Dolby Vision would not be detected when connecting to some LG or Samsung soundbars
-Fixes bug where screensaver would not be displayed in Netflix
-Fixes bug where "Match Color Space" was not working properly on some TVs
-Fixes stutter issue observed when playing interlaced video for ~15 minutes
-Fixes system hang issue when enabling/disabling "Match content color space" while playing Dolby Vision content on Netflix
-Reduces occurrences of red flashes when watching Dolby Vision content
-Fixes bug where "Match frame rate" would not work on Dolby Vision content

Audio
-Disabling "Fixed Volume" will now disable Dolby audio processing
-Fixes bug where Atmos streams would still be detected even if non-Atmos content is played
-Fixes bug where audio would not be heard on Vizio TVs when streaming from VUDU/Movies Anywhere
-Fixes bug where audio popping would be heard on headphones when Dolby audio processing is enabled
-Resolves issue with high bit rate audio dropping audio at fixed locations. Note: This fix will apply to apps using SHIELDs audio engine like -Plex/Photos & Videos. Kodi has its own engine which has not fixed this bug yet so the fix will not apply to Kodi and apps like it.
-Adds 16-bit DAC support for Dolby Decoded content
-Fixes bug where audio passthrough was not available over USB DAC on 3rd party apps like KODI (Requires KODI 18.5 or 18.6 nightly builds) -Fixes bug when manually setting "Audio formats" would not be applied
-Fixes bug when using Google Home where volume would be reduced but not restored
-Fixes rare bug where IR volume control would stop working
-Resolves audio routing issues when using multiple USB devices (e.g. webcam + USB DAC) -Adds support for Sanskrit USB DAC -Fixes bug where PCM would be streamed if Dolby ATMOS is manually selected in "Available Formats"
-Displays correct audio stream name under and adds detection support for EAC_JOC(DD+) streams (Settings -> Status-> HDMI ->Audio Mode)
-Fixes bug where audio would not play after enabling PCM output only mode (Available formats)

Network
-Fixes issue transferring large files when connecting PC to SHIELD
-Fixes bug where soft reboot would be seen when "Restart Wi-Fi" was selected

Accessories
-Adds support for XBOX Elite 2 controller
-Add bluetooth support for WeChip G30 remote
-Adds IR volume control support for Logitech Z906 speaker system
-Fixes crash issues when accessory update notification is seen -Fixes bug where IR control setup would fail on Samsung AVR/soundbars
-Fixes bug where IR control would not function when Talkback is enabled
-Fixes bug where IR volume control would stop working when enabled
-Fixes bug where remote locator would not work when SHIELD is asleep
-Improves volume control for 2015 remote and controller
-Fixes SHIELD Remote 2019 bug where battery would drain quickly when IR control enabled
-Fixes bug where "send Menu command to app" was not working properly
-Resolves pointer issue when using RS mouse on network captive portal registration
-Fixes rare bug where pressing power button would not sleep SHIELD if video is playing
-Improves SHIELD stability when connecting multiple Bluetooth devices

Other
-Fixes bug where "Dolby Vision" quick setting is not updated according to display setting -Channels DVR app can now store recorded content over NAS
-Fixes bug where pre-installed apps would disappear
-Fixes issue where long press home would not bring up NVIDIA Share
-Fixes bug where settings would crash when selecting system language
-Adds message informing user AI upscaling not available on rooted/unlocked devices
-Fixes bug where "Ok Google" hotword activation requires reboot
-Resolves rare bug where Netflix would crash when invoking app switcher (double press home) -Improves text when displaying most recent SHIELD wake event (Settings -> About -> Status -> Uptime)
 

Arrow0309

Active Member
Yeah it did that, cheers.

Full list of fixes are:

Bug Fixes/Enhancements: Video/Display
-Resolves issues detecting Dolby Vision TVs that also support HDR10+
-Resolves brightness issue on TVs that support Dolby Vision and HDR10+
-Resolves cast playback issues when switching between HDR and SDR content
-Fixes bug where Dolby Vision would not be detected when connecting to some LG or Samsung soundbars
-Fixes bug where screensaver would not be displayed in Netflix
-Fixes bug where "Match Color Space" was not working properly on some TVs
-Fixes stutter issue observed when playing interlaced video for ~15 minutes
-Fixes system hang issue when enabling/disabling "Match content color space" while playing Dolby Vision content on Netflix
-Reduces occurrences of red flashes when watching Dolby Vision content
-Fixes bug where "Match frame rate" would not work on Dolby Vision content

Audio
-Disabling "Fixed Volume" will now disable Dolby audio processing
-Fixes bug where Atmos streams would still be detected even if non-Atmos content is played
-Fixes bug where audio would not be heard on Vizio TVs when streaming from VUDU/Movies Anywhere
-Fixes bug where audio popping would be heard on headphones when Dolby audio processing is enabled
-Resolves issue with high bit rate audio dropping audio at fixed locations. Note: This fix will apply to apps using SHIELDs audio engine like -Plex/Photos & Videos. Kodi has its own engine which has not fixed this bug yet so the fix will not apply to Kodi and apps like it.
-Adds 16-bit DAC support for Dolby Decoded content
-Fixes bug where audio passthrough was not available over USB DAC on 3rd party apps like KODI (Requires KODI 18.5 or 18.6 nightly builds) -Fixes bug when manually setting "Audio formats" would not be applied
-Fixes bug when using Google Home where volume would be reduced but not restored
-Fixes rare bug where IR volume control would stop working
-Resolves audio routing issues when using multiple USB devices (e.g. webcam + USB DAC) -Adds support for Sanskrit USB DAC -Fixes bug where PCM would be streamed if Dolby ATMOS is manually selected in "Available Formats"
-Displays correct audio stream name under and adds detection support for EAC_JOC(DD+) streams (Settings -> Status-> HDMI ->Audio Mode)
-Fixes bug where audio would not play after enabling PCM output only mode (Available formats)

Network
-Fixes issue transferring large files when connecting PC to SHIELD
-Fixes bug where soft reboot would be seen when "Restart Wi-Fi" was selected

Accessories
-Adds support for XBOX Elite 2 controller
-Add bluetooth support for WeChip G30 remote
-Adds IR volume control support for Logitech Z906 speaker system
-Fixes crash issues when accessory update notification is seen -Fixes bug where IR control setup would fail on Samsung AVR/soundbars
-Fixes bug where IR control would not function when Talkback is enabled
-Fixes bug where IR volume control would stop working when enabled
-Fixes bug where remote locator would not work when SHIELD is asleep
-Improves volume control for 2015 remote and controller
-Fixes SHIELD Remote 2019 bug where battery would drain quickly when IR control enabled
-Fixes bug where "send Menu command to app" was not working properly
-Resolves pointer issue when using RS mouse on network captive portal registration
-Fixes rare bug where pressing power button would not sleep SHIELD if video is playing
-Improves SHIELD stability when connecting multiple Bluetooth devices

Other
-Fixes bug where "Dolby Vision" quick setting is not updated according to display setting -Channels DVR app can now store recorded content over NAS
-Fixes bug where pre-installed apps would disappear
-Fixes issue where long press home would not bring up NVIDIA Share
-Fixes bug where settings would crash when selecting system language
-Adds message informing user AI upscaling not available on rooted/unlocked devices
-Fixes bug where "Ok Google" hotword activation requires reboot
-Resolves rare bug where Netflix would crash when invoking app switcher (double press home) -Improves text when displaying most recent SHIELD wake event (Settings -> About -> Status -> Uptime)
Still giving me headache with the muted colours, damned color space
 

BeardlessKoala

Active Member
Has the Shield Pro 2019 model been discontinued? It's out of stock everywhere and the ones on eBay have shot up to ridiculous prices :(
 

JabbaNut

Well-known Member
Has the Shield Pro 2019 model been discontinued? It's out of stock everywhere and the ones on eBay have shot up to ridiculous prices :(

Where are they made and assembled ?
 

graymattor

Standard Member
Not sure if this a daft question or not, but what settings are ppl using for playing 4K HDR content from their NAS/HDD?

I'm getting a grainy affect and I'm wondering if it's my settings on the sheild or all my content is rubbish?

Thanks
 

chopples

Well-known Member
Not sure if this a daft question or not, but what settings are ppl using for playing 4K HDR content from their NAS/HDD?

I'm getting a grainy affect and I'm wondering if it's my settings on the sheild or all my content is rubbish?

Thanks
In all honesty it’s probably the source, for Filmmakers grain is often intended. The only thing I would say is certain TV processing can attenuate it, for example I have a Samsung Tv, if I was to turn on the contrast enhancer it would make the grain distracting as it dithers on the scene.Personally I would recommend turning off as much of your TV processing as poss, even if it does appear to brighten the image as it is also likely to introduce noise and other oddity’s into the picture
 

graymattor

Standard Member
Thanks, it looks like it it's my in experience with 4k, it looks as though that's the way it should look but you are 100% correct all these fancy setting (I have a samsung Q85R) a lot of the time make things worse, what you have described is exactly what I'm experiencing. At least it's nothing faulty and I'm not going mad lol. Thanks
 

chopples

Well-known Member
Thanks, it looks like it it's my in experience with 4k, it looks as though that's the way it should look but you are 100% correct all these fancy setting (I have a samsung Q85R) a lot of the time make things worse, what you have described is exactly what I'm experiencing. At least it's nothing faulty and I'm not going mad lol. Thanks
With the qleds the temptation is to mess with settings to get a picture comparible to the Samsung demo's . It's pretty easy to lose track of what's been changed and as u say more often the picture can look worse, unless you can keep track then a reset is the only way to fix it. I would also say to ignore certain recommendations, such as white balance and CMS, these values are determined by using a colour meter attached to the screen. Every display has different properties, it also takes a long time punching these things into the TV. In all probability it will make the image worse


The reality is most movies will not look like demo material, old films are likely filmed at 35mm giving us the resolution we need but often introduces artifacts associated with the analogue formats, I don't mind stuff like grain or for example the shutter technique used in saving private Ryan, I prefer it compared to the overly clean digital movies we see today but I appreciate this is a matter of taste, my wife for example can't stand it and complained when we watched the matrix. But with that movie I was just made up they had removed the green tint.

There where also problems when movie makers started using digital as they tended to use 2k digital intermediaries, they obviously never had the foresight to see where the market was heading.
 

graymattor

Standard Member
With the qleds the temptation is to mess with settings to get a picture comparible to the Samsung demo's . It's pretty easy to lose track of what's been changed and as u say more often the picture can look worse, unless you can keep track then a reset is the only way to fix it. I would also say to ignore certain recommendations, such as white balance and CMS, these values are determined by using a colour meter attached to the screen. Every display has different properties, it also takes a long time punching these things into the TV. In all probability it will make the image worse


The reality is most movies will not look like demo material, old films are likely filmed at 35mm giving us the resolution we need but often introduces artifacts associated with the analogue formats, I don't mind stuff like grain or for example the shutter technique used in saving private Ryan, I prefer it compared to the overly clean digital movies we see today but I appreciate this is a matter of taste, my wife for example can't stand it and complained when we watched the matrix. But with that movie I was just made up they had removed the green tint.

There where also problems when movie makers started using digital as they tended to use 2k digital intermediaries, they obviously never had the foresight to see where the market was heading.
Thanks, these are things due to me being very naive would never know or expect, this is why I love this forum, the amount of AV industry knowledge is outstanding and I love learning from you guys.

I have played with the setting ALOT and like you said it's easy to get lost with what you have changed! I have reset all sources and I'll turn off the fancy correction settings and see how I get on.

Thanks again for being so accommodating with my lack of knowledge and experience 👍
 

nero0410

Distinguished Member
Has the Shield Pro 2019 model been discontinued? It's out of stock everywhere and the ones on eBay have shot up to ridiculous prices :(
Was going to buy one last week, didn't quite have the funds as Amazon had 3 in stock.. out of stock again..

I'll be jumping on one as soon as they come back in stock!
 

Robothamster

Distinguished Member
Lip Sync.... so annoying.

Watching Prime, YouTube etc, fine. Netflix however seems to always have a tiny sync issue - I back out and go to Shield settings and mess with the built in Audio Sync adjuster and back into Netflix again and it is often OK - but then next time I start Netflix again it's out :mad: And I'm talking about adjusting it between 0ms, 10ms or 20ms, so a really tiny amount - yet I can see it and it is frustrating.
 

rosscouk

Member
I have had the original shield since it first came out. Its always been good at running Kodi and plex, but I always found watching Netflix and laterly Amazon apps sub-opitimal. I hadnt tried using either for a while, but I invested in a logitech remote recently and I liked the idea of trying to use the shield again as its then much easier for the family.

Anyway, we have been using Netflix again on the shield and its been pretty good, no obvious flicker issues that I remember from a few years ago. However tonight we tried to watch Amazon and to start, the sound sync was off, then once I adjusted that in the shield settings, the image was also quite jerky when playing, this issue seems to stay there. If I then switch to the same app on my LG Oled, they had neither problem, no lip syncing issue or jerky image.

My system is a Shield into a Denon 3300 av amp and an arc back to LG C8.

Any thoughts? I just really want to use the shield as a complete media hub, buts it never quite been that.

Does the latest pro version have similar issues?

Is there anything I can do to improve the amazon prime experience?
 

chopples

Well-known Member
I have had the original shield since it first came out. Its always been good at running Kodi and plex, but I always found watching Netflix and laterly Amazon apps sub-opitimal. I hadnt tried using either for a while, but I invested in a logitech remote recently and I liked the idea of trying to use the shield again as its then much easier for the family.

Anyway, we have been using Netflix again on the shield and its been pretty good, no obvious flicker issues that I remember from a few years ago. However tonight we tried to watch Amazon and to start, the sound sync was off, then once I adjusted that in the shield settings, the image was also quite jerky when playing, this issue seems to stay there. If I then switch to the same app on my LG Oled, they had neither problem, no lip syncing issue or jerky image.

My system is a Shield into a Denon 3300 av amp and an arc back to LG C8.

Any thoughts? I just really want to use the shield as a complete media hub, buts it never quite been that.

Does the latest pro version have similar issues?

Is there anything I can do to improve the amazon prime experience?
Hi mate

you could try the refresh rate switching tool from the play store? I expect a refresh rate mismatch is the reason for jerky performance.

Apart from Netflix outputting DV and lossy atmos the performance (and any judder issues) will be the same between the old and new shield
 

Marvt74

Active Member
Just picked up the Shield tube thing, but can't stop the niggling feeling that i should return it and wait for stock of the Pro.

I'm not bothered about gaming, the main use is for Kodi and this replaces the 2nd gen Fire TV. It seemed to work ok last night on a brief play, although some elements of Kodi did seem to have longer "egg timers" than i'd have expected.
 

BeardlessKoala

Active Member
Scan has listed the Pro version as in stock on the 25th March. I've pre-ordered it :clap:
 

BeardlessKoala

Active Member
Scan's website now lists the pro version as due on May 28th :(. Hope that is new orders. I had an email two days ago saying they estimate my order to ship March 25th so fingers crossed it's still that date for me 🤞 The shortage must be because of the Coronavirus
 

bubblegum57

Well-known Member
A few months ago, any problem was due to brexit, now it's coronavirus :)
 

nix

Active Member
I've just bought the 2019 tube as an upgrade for my LG B8 from a 2017 shield.

I've been switching between basic and AI medium and I can't see a difference on my 1080 streams. Am I doing something wrong?
 

Robothamster

Distinguished Member
I've just bought the 2019 tube as an upgrade for my LG B8 from a 2017 shield.

I've been switching between basic and AI medium and I can't see a difference on my 1080 streams. Am I doing something wrong?
Have you activated the slider so you can see the difference in real time?
 

Robothamster

Distinguished Member
I did. It seemed so subtle that was wondering if it worth the upgrade
I had been watching Mr Robot (1080p)on the Shield and I could tell the difference between it being on or off, but yes it was pretty subtle.
 

Trending threads

Latest News

Huawei launches Vision X65 OLED TV in China
  • By Andy Bassett
  • Published
Virgin Media adds more free Sky channels
  • By Andy Bassett
  • Published
Disney Plus reaches 50 million subscribers globally
  • By Andy Bassett
  • Published
Samsung to end Smart View app support on older TVs
  • By Andy Bassett
  • Published
Leema Acoustics offers factory shipping for locked down customers
  • By Andy Bassett
  • Published
Top Bottom