• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Not getting Dolby Surround in Games

GT_Nige

Standard Member
I've finally got my new PC up and running but am having trouble getting 5.1 surround. I don't have a separate sound card but my Gigabyte Z68AP-D3 motherboard is capable of 5.1. I've tested it in sound settings and it tests each speaker individually as it should.

Is there a setting somewhere to enable in game? I can't find anything in Steam or the games themselves

Thanks
 

KhalJimbo

Distinguished Member
Do you use headphones or speakers? I'm pretty sure for headphones you need to use Dolby headphone. I'd imagine it should be a default in games in the audio options.

I know in DA:II you get to force stereo mode, so 5.1 is by default. I'd think it the same for many games. Have you got the latest realtek HD audio drivers? I have the same mobo as you but I dont use 5.1 yet. I asked my wife for a pair of the Corsair HS1 surround headphones for Christmas but that uses USB.
 

TheNameIsJambo

Distinguished Member
I believe Realtek onboard has some problems with Skyrim. Do you get surround sound support in other games?

You can either wait for a Skyrim patch from Bethesda or Realtek, or buy a Xonar DG soundcard on the cheap (£20) or go a bit upmarket and get a Xonar DX.

Do you use headphones or speakers? I'm pretty sure for headphones you need to use Dolby headphone. I'd imagine it should be a default in games in the audio options.

I know in DA:II you get to force stereo mode, so 5.1 is by default. I'd think it the same for many games. Have you got the latest realtek HD audio drivers? I have the same mobo as you but I dont use 5.1 yet. I asked my wife for a pair of the Corsair HS1 surround headphones for Christmas but that uses USB.

On the contrary, you only need to enable DS3D GX mode on an ASUS Xonar card, I think the same 'Game' mode applies for Creative - Enabling EAX? That's what delivers the positional cues :)

The only feature that Dolby Headphone adds is reverb, to make it sound more 'life-like'.

The feature really annoyed me when I was playing Saints Row 3, everyone sounded like they were standing in a studio, talking to me through multi-directional speakers via a microphone. Quite literally, it sounded like they were standing in the middle of an echoey room.
 
Last edited:

GT_Nige

Standard Member
I've checked all the drivers through windows and it says they're all up to date, unless there's another way? Sorry I'm totally new to PC gaming. I do have some Astro A40s but they don't sound as crisp and directed as they do on the PS3 and 360, so I imagine they aren't putting out 5.1 either. I forgot to mention that it does seem to be putting out surround on the front 3 and sub. (is that 3.1 or 2.1?)

Yeah I wondered if it was just Skyrim as that was the first game I played, however it's the same on Mass Effect 2. I've not tried any others as they're still downloading.
 
Last edited:

TheNameIsJambo

Distinguished Member
Check that your onboard codec is definitely set to '5.1' within Windows and on your Realtek software.

Right click on the speaker icon(s) -> Properties -> Advanced. It will be hiding in there somewhere.
 

GT_Nige

Standard Member
Think you may be onto something. I've had a look and it only lists 2 channel formats under the advanced tab. The confusing thing is under the 'Supported formats' tab I click on Dolby Digital then click test and it does each channel individually.

I'm wondering if it's just lack of support for games... Still doesn't make sense though..:confused:

In fact what I said about 3.1 is wrong. I am just getting 2 channel
 
Last edited:

The latest video from AVForums

CES 2023 Round Up: New TV Lineups for 2023 from LG, Samsung, Panasonic, Hisense & TCL
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom