Noisy Fan Teac AG V-8520 receiver

Jackson1181

Novice Member
The fan in our Teac AG V-8520 receiver is noisy all of a sudden. We took it apart, and the blades in the fan are not hitting, so we feel it is the motor. We cannot find Teac replacement parts online. Can we substitute another fan motor? Any suggestions would be appreciated!
 

fxv300

Active Member
Is the fan made by TEAC? With fans they are usually easy to substitute. They are only a few quid each new. When they become noisy it usually is the motor. I have a box full of them from laptops, PCs and all sorts of things. They are mainly 12V or 6V and 3 or 4 pin to connect. Post a picture of what you have, there is normally a label on the fan motor.
 
Last edited:
Upvote 0

Jackson1181

Novice Member
IMG-2648.jpg
 

Attachments

  • IMG_2642.jpg
    IMG_2642.jpg
    255.7 KB · Views: 14
  • IMG_2646.jpg
    IMG_2646.jpg
    181.8 KB · Views: 14
Upvote 0

Jackson1181

Novice Member
Thank you for your reply! The motor only has 2 pins and doesn't specify the voltage.
The number on the side of the motor is: MDN4RB4MRC
We have tried searching the number and it only shows as unavailable.
thanks!
 
Upvote 0

fxv300

Active Member
I see from the pictures it has unique fitting lugs etc, probably best to contact TEAC support unless you can find something online which can do the job. If you search google for MDN4RBMRC which is from your picture you will find lots of hits, looks like that fan is also used on Technics and Panasonic kit. Hope that helps. You will need to solder it in place so make sure which wire goes where if you ever get one. Good luck.


 
Upvote 0

The latest video from AVForums

Toy Stories - Turning Toys into Blockbuster Movies
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom