• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

No Yamaha 663 OSD over HDMI

mpe

Standard Member
Hello,

I've just bought the Yamaha RX-V663 receiver and have problem with OSD functionality. It is connected to the Samsung LE40N87 LCD via HDMI.

The 1080i passthrough from my cable STB works fine. However, when I press the button on the remote to enter OSD or connect DVD player via the component input, no signal is displayed and LCD reports "mode not supported".

Of course I can set everything on the receiver display, but this should work.

Do you know what could be wrong?

Mirek
 

Andy98765

Distinguished Member
Are you sure the OSD works through HDMI, for example on my Cambridge AV amp it only works through Composite or S-Video. Do check your instructions, it is only a thought?
 

mpe

Standard Member
Are you sure the OSD works through HDMI, for example on my Cambridge AV amp it only works through Composite or S-Video. Do check your instructions, it is only a thought?

Well, it should work according to the manual. This receiver is relatively recent model that should have not only OSD via HDMI, but also upconverting feature for analogue inputs. As I understand it I should be able to connect DVD player via component input and have it to be converted to HDMI.
 

Member 116841

Distinguished Member
All Yamaha AV amplifiers and receivers incorporate i/p conversion, so this shouldn't be a problem. You may have to enable it in the video setup menu.
 

chuckadkins

Standard Member
Unboxed and started setting up Yamaha HTR-6150BL 630 Watt 7.1-Channel Home Theater Receiver last night.

I cant seem to get the video upscale/hdmi bit working. Ideally I would like to connect the HDMI monitor out to my TV, and no other wires.

AppleTV, TiVO3 (connecting to the receiver via HDMI) work great - however Wii (using video), YDS-11SL Universal iPod Dock (proprietary connection) and the OSD GUI only display when I use the video monitor out.

Anyone have any ideas?
 

aigarspolis

Standard Member
All who experiencing problems with not showing OSD menu over HDMI or DVD is not passing video over HDMI to LCD TV. All you need is buy correct HDMi cables category 2 or with label 1.3 ...that's it ! No need for brand cables just 16 EUR for cable will be fine. After changed to HDMI 1.3 cables are working OSD menu and no problems connecting DVD/BD video through my Yamaha RX-V663 amp to LCD TV. :thumbsup:
 

charles101

Standard Member
Hello,

Has anyone with this problem tried buying a new HDMI cable? i thought the HDMI cable I purchased was version 1.3 but Im getting this problem still !
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom