1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No subwoofer activity from Sony STRDE695

Discussion in 'AV Receivers & Amplifiers' started by kyouki, Aug 9, 2004.

Tags:
  1. kyouki

    kyouki
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hello!

    I hope someone can help me troubleshoot this.

    I just bought a Sony STRDE695, but I'm getting nothing from the subwoofer!

    I basically cannibalized my old system (Cambridge Soundworks Desktop Theater 5.1 DTT2500) for speakers. Purchased some Panasonic speakers to replace the the Center, L, and R speakers. Moved the old Center behind me for use as the Rear Center.

    I plan on eventually getting all new speakers but for the time being I just wanted to get the reciever so I can build up as I save money here and there.

    I got everything working fine except the sub!! I get nothing from it.

    Note: the subwoofer inputs are like your standard speaker input: two clamps, red and black. The cord I use has bare speaker wire on one end and a coaxial connector at the other end. I plug it in and nothing. Just to be sure, I plugged the sub back into the system it came from, and it works with no problem.

    As for settings, I set Subwoofer to "YES" and all speakers to "SMALL."

    I don't have the remote (bought an open box special), so I don't know how to generate a test sound. I fired up DVD Digital Video Essentials and the audio test there went fine until it got to the sub, where no noise could be heard. I played some XBox games, and nothing from the sub. Fired up some music... nothing. Skipped to the chainsaw scene in American Psycho... still nothing from the Sub!!

    Has anyone had any experience with this? What could lead to subwoofer not working on a receiver? I hope it's not the receiver that is malfunctioning, though I do have 30 days to return it if it is... though I'll lose the good deal I got since it's the last one in the store.

    Please help!!

    Thanks,
    Al
     
  2. ktng

    ktng
    Standard Member

    Joined:
    May 9, 2004
    Messages:
    171
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    UK
    Ratings:
    +0
    Looking at the DTT2500 manual it looks like it uses a passive subwoofer and you need an active subwoofer to work from your Sony receiver. You may be able to hook it up in some way to use the amp/processor from the DTT2500 - although I'm not sure how you would connect it up, but I don't think you would be able to use the bass management of the Sony receiver.
     
  3. kyouki

    kyouki
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks so much for the quick reply!

    I'll go pick up a powered subwoofer today.

    Thanks again!
     

Share This Page

Loading...