• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

No sound

snapper69

Standard Member
Hi, I'm new to this forum, so please excuse me if this question has been covered before. I did have a look, but I couldn't see anything.

I have a 32" LG Lcd set, a Thomson Sky HD box and a PS3 connected to the single HDMI socket through a 3 way switching box. This has worked well for several months, however on Monday we lost the sound on all the Sky channels. I tried various things e.g connecting the HD box directly to the TV but came to the conclusion that the HD box was Fubar. I called Sky. They tried. Then I plugged the PS3 into the TV and got no sound, so it looks like the HDMI socket is u/s. I went back to scart, not good.

I was wondering if it was possible to connect the HD box via HDMI for the picture quality and make a different connection for the sound, either directly to the TV or to an old Sony AV system?

Thanks:lease:
 

upthespurs

Standard Member
You could try connecting both the PS3 and the SKY HD receiver using an Optical cable to the AV system, if it has one, or failing that use the red and white audio outs.
 

kenedin

Prominent Member
Make sure you double check the Sound Settings on your TV.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom