• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

No sound with turntable/phone/receive/speaker connection

nicholasfia

Novice Member
Hello All,

AV noob here.

I recent purchased a few items for my mother so she could play her 45's in her new place:

Sony STR DE 598 receiver - back shown here: http://www.fein-hifi.de/images/product_images/original_images/1360_6.jpg

PP400 Phono Preamplifier

Stanton T50x

JBL Loft 40 bookshelf speakers - I purchased basic polarized speaker cable

Problem is, I'm not getting any sound!

I'd love to know how/where everything should be hooked-up... I really feel like I'm missing something - I guess the lack of sound gave it away lol.

Please let me know if you can offer some advice. It's appreciated!

Nick
 

Rodders53

Distinguished Member
:rtfm: Support for STR-DE598 | Sony may help?

It appears to have a speaker switch control on the front that could have some affect on sound output? (as well as selecting the correct source input).

Try headphones as well as the speakers?

Try connecting a FM aerial and selecting that instead of the phono amp to get some sound (even if only a hiss when you tune a poor station in)?

Or an mp3 player (mobile phone) via a stereo mini jack to phono cable.
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom