• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

no sound to 5.1 speakers from tv

bo74

Standard Member
hello, i`ve got a panasonic G20 tv and recently got a 5.1 speaker set and an
onkyo tx-nr579 receiver.....set it all up today and getting sound through the speakers from blu-ray player and radio on receiver.....but can`t get sound from tv through speakers,
this is my 1st receiver and surround set.....totally new to this and surprised i`ve got sound coming through at all really lol.
so i`m not sure if its something to do with a tv setting or receiver setting that i`m overlooking,
i`ve got hdmi connected from receiver to ARC on tv, apart from this i`m not sure what other info to give...and obviously i`m at a loss.
hoping somebody can give me some help/advice wich will be gladly received.
 

bow79

Active Member
I have not had any personal experience of this. I have just googled Panasonic g 20 hdmi arc and there is some information including earlier threads from AV forums good luck.
 

lucky247

Active Member
If I remember correctly. Turn everything on and press TV at top of Panasonic remote. Then press Viera Link on Panny remote (left of direction arrows) Then you should be able to switch between tv sound and home cinema sound.

I also think it depends on the HDMI cable though. I'm pretty sure it's only the newer HDMI cables that send picture and sound both ways. But I could be wrong.

Good luck!
 

bo74

Standard Member
ok thankyou.....just been googling and it seems a few have had this problem but didn`t find any
direct solutions.....just tried the viera link but getting " feature not available" for some reason,
thanks again....its probably just a matter of pretty much doing as you`ve said but confused atm why viera link
isn`t working aswell.
 

bo74

Standard Member
p.s. got latest hdmi connected aswell.....1.4 ......at least thats what i was told i was buying anyway.
 

Joe Fernand

Distinguished Member
AVForums Sponsor
HDMI ARC is not cable dependent - HDMI :: Manufacturer :: HDMI 1.4 :: Audio Return Channel

HDMI cables are not ‘version’ compliant – your cable is either Standard or High Speed.

Assuming your TV and AVR both support ARC this is a handshaking or User Setup problem.

If you have changed something in your system its always worth powering the lot off at the wall then repowering and then look for the ARC enable option on the TV and AVR.

Ensure your TV and AVR are both running the latest Firmware – should be available from the Manufacturers website.

Joe
 

bo74

Standard Member
sorted it!....i hadn`t turned on hdmi control (RIHD) from onkyo setup menu....doh!
totally new to the home cinema/av receiver set up so a simple mistake was inevitable i think,
thanks v much to all replys.
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom