No sound output through HDMI2 or optical on Panasonic TX-P42G20B

ultravox72

Standard Member
I recently purchased a "Yamaha RX-A1010" to connect to my "Panasonic TX-P42G20B" with also my panasonic blu-ray player, humax freesat etc.
All sound inputs & outputs are fine except for the tv.
The instructions state that there is audio return on HDMI2 which did work for a short time but then stopped. I then decided to try the optical lead, again this did work but stopped again when I switched tv back on.

Initially I had to press vierra link button to select home cinema, but I no longer have that option - it states "service unavailable". I have tried switching off the tv, unplugging from the mains etc, various different HDMI leads but still cant get audio pass through to work on the HDMI2 or any other hdmi port.
I have also tried to find a different firmware to see if this would fix the problem. I haven't tried updating this yet, but would it actually solve the problem I have got?
I have also checked the settings on the amp and tried switching the HDMI controll on & off (which initially fixed the problem) but still no joy :(
Any help much appreciated! :lease:
 

StevieBuck

Well-known Member
Have you re-selected the correct input on the receiver for the TV (i.e the optical or HDMI depending on what you are using)?
 

ultravox72

Standard Member
Yes, tried everything!..strange that it worked for a short while - I lost the option of selecting "home cinema" from the menu. It just keeps stating feature unavailable.
Someone has sugested to me to reset the tv to factory settings - I was reluctant to do that at first as i do have an external hard drive plugged into the tv to record off freeview but i am told it shouldnt affect that.
I will have another go at the weekend.
 

ultravox72

Standard Member
:mad: I've tried everything now. I bought proper panasonic HDMI lead, checked firmware on tv (latest one), reset tv to factory settings, did a "reinitialize" on av-amp.
Stil no joy :(
Every time I press "Viera link" on tv remote I just get "Feature Unavailable".
Looks like I will just have to resort to using phono out from tv :(
I have googled this problem as well and looks like other people have been having issues with this as well.
What I don't understand is the fact that I got it to work once!!
(actually twice!!)...that's why I thought reset everything to factory default and it would work again!!
If i'm missing something pretty obvious please tell me!:lease:
 

ultravox72

Standard Member
:rolleyes: After spending most of my Sunday afternoon on it I finally got audio through optical lead.I've given up on the viera link!
Must be a problem with HDMI port on tv as the tv always stated "feature unavailable" every time I press the button on the remote.
Thanks for everyone's input on this.
Everything else connected to my av receiver works fine. Blu-ray, HD director multimedia drive (via HDMI), Humax freesat box (HDMI), Wii (component), Screenplay Multimedia drive (S-video + optical cable).
Mp3 player via phono.
I think my next TV will be a samsung!
 

Trending threads

Top Bottom