• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Question No sound from HDMI device to soundbar via Optical

pcdunk

Established Member
Having a strange problem. Purchased a new Panasonic TX-50CX802B TV to replace my TX-L47ET60B
The TV is connected to a Yamaha soundbar via optical.
I have a Panasonic recorder, Apple TV and an elderly Philips HDT-8520 PVR connected to the TV via HDMI.
All working fine

Now when I moved everything to the new TV I find I have no sound from the Philips box only picture.
swapped all cables and moved the Philips box to a different HDMI input but still no sound.
Panasonic box and Apple TV work fine.

Can't find any setting to change could it be the Philips box is too old to work with the new television
Anybody got any ideas ?? Thanks
 

JayCee

Distinguished Member
Try disconnecting the Philips PVR from the mains supply for 5 mins then plug it in again and try it.
 

pcdunk

Established Member
Thanks for the info. Tried that and it didn't help. Going to return the set due to other issues (off axis viewing not to great compared to my TX-L47ET60B which has IPS screen
 

The latest video from AVForums

Spielberg, Shyamalan, Aronofsky, Chazelle, Eddie Murphy and Mel Gibson - all the latest movies
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom