"No signal" error on Goodmans GDB1225DTR Digital TV Recorder

RichJW

Novice Member
Hi all,

I've come to this group, as Goodman's couldn't offer any support at all, other than a factory reset, which I'd like to avoid.

I hope someone can help with regards to an issue with my Grandfather's Goodmans GDB1225DTR Digital TV Recorder.

Quite regularly he will receive a "no signal" error message when viewing a recording on the box, and that particular bit of the programme will not be viewable. He will need to restart the programme and go beyond where the error occurred.
The TV itself works fine and the issue has occurred with 2 TVs, so the TV can be ruled out.

It is all connected correctly as according to the manual, which is...
Aerial to RF In 1
Loop through cable from RF Out to RF In 2
Scart connected to TV port

I have reconnected the cables and gave them a blow to remove any static build up. I have also retuned it, with no change to the issue.
The way I see it, it has to be the aerial, the aerial cable, the loop through cable, or the recorder itself. I can try a loop through cable when I'm next there, as I have a spare one, however I doubt that is the issue. Is there a good method of finding out (other than having to buy another recorder!)?

Many thanks,
Rich
 

mikej

Well-known Member
I would first check your signal strengths on the Goodmans box. Judging by the manual, you can find that in the System Information menu. Ideally you'd want to check all the different Freeview muxes but if you're not sure what channels that would involve, then go through a random selection (including the channels that are likely to be recorded) and check the signal strengths are strong enough. This can vary from device to device, but I'd say you'd want at least 70% - preferably higher.

Those small loop-through coax cables are needed for recording from multiple tuners at once and are usually provided with the PVR. If your problem is sporadic, it might only be occurring when two programs are being recorded at once, so that cable could be a potential cause. They're often poor quality and can suffer from being bent round at a fairly severe angle due to their small size, which can affect signal strengths on the second tuner and lead to problems. Temporarily replacing it would be an option if you're trying to troubleshoot signal strength issues, as would checking the aerial outlet plate on the wall and the other coax fly-lead cable are both sound and secure.

If your signal strengths all look fine, then doing a factory reset might be a good idea. You would need to retune and re-set your timers afterwards but you should keep all your recordings - these are only usually lost when you specifically reformat the drive, but you might want to check this is definitely the case on your Goodmans model first by checking the manual, which can be found here if you don't have a paper copy.
 

RichJW

Novice Member
Thanks @mikej
I'll test those out next time I'm there and will take a replacement loop-through cable just in case.
Appreciate your detailed response.

Rich
 

The latest video from AVForums

AVForums Movies Podcast: Which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom