• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

No Netboot on new iMac? (DeployStudio)

Theydon Bois

Distinguished Member
Just got some brand new iMacs that I was going to use DeploySTudio to roll out Lion (the rest of our Macs and the Mac Server are all Lion) but the first one I tried will not even boot to DeployStudio.

DeployStudio service is running ok, as is the Netboot servoce but pressing N on the client starts with the world icon, but then just sits there with the apple logo, not actually getting to the Deploystudio client.

I even went through the setup process on the (Mavericks) iMac, to get to the startup disk option to choose the startup disk as network but still no joy.

I have read that perhaps my DS may be not the latest version, or that possibly trying to apply an image to a newer machine etc, but its not getting to the DS client to then error.

I did the PVRAM clear as well at one point as it seemed as though it was stuck on a network boot (restarting just stuck on the grey screen) which allowed it to boot again.

Sorry for the ramble, not sure what I need to try next - I will be in early to see if I have a dud machine and will try another one.
 

Theydon Bois

Distinguished Member
Some further info:


I disabled the second nic on the mac server in case that helped.

Stopped and restarted the Netboot service

Tried another Mac (not gone through the account creation process yet)

Noted that in the log of the netboot service, both test Macs show (DHCP given IP addresses)

Both Macs are just stuck on the grey screen with an Apple logo currently.

The Netboot service reports:

Netboot MAC OSX Enabled 0

Netboot Mac OSX diskless Enabled 0

Netinstall Mac OSX Enabled 1, NFS Running, DHCP Stopped

Netboot Mac OS 9 Enabled 0
 

Theydon Bois

Distinguished Member
Just in case you wanted to know, its because my images were older than the hardware.
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom