No low range on my old Mission 780s

Discussion in 'Home Cinema Speakers' started by jimok78, May 8, 2007.

  1. jimok78

    jimok78
    Standard Member

    Joined:
    Oct 2, 2006
    Messages:
    36
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +0
    Morning all.

    Ive got a bit of a problem! I have some oldish (probably about 4 years) mission 780s which were made redundant about 3 years ago when I bought some B&W 603 S3s. I decided to get the 780s out from the loft for use downstairs with a cheap amp from Richer Sounds. On connecting everything up I was a bit startled to find the low end doesnt seem to be working (when bi wiring). I thought it may be the amp (Cambridge Audio A5), so swapped it for my Arcam A85 (which should be more than enough to power the speakers). But still no joy. :( . Has anyone had any similar problems? They have been in the loft for a couple of years but can imagine this would cause the problem - Ive also taken the backs off the speakers and everything looks ok (admitedly I havent put a multi meter on them or anything yet).

    Any suggestions greatly appreciated.
    Thanks
    James.
     
  2. Nobber22

    Nobber22
    Well-known Member

    Joined:
    Jun 6, 2002
    Messages:
    2,982
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Berkshire
    Ratings:
    +111
    The larger Mission 782 are known to have a problem with "leaking" woofers that stop working - yours could have similar issues? I think Mission used to fix them under warrenty/goodwill, but it may be a bit late for that? :(
     
  3. jimok78

    jimok78
    Standard Member

    Joined:
    Oct 2, 2006
    Messages:
    36
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +0
    Interesting you should say that - when you say leaking do you actually mean phsyically leaking!? I noticed a while back that there was some moisture on the cones and just assumed it was condensation.
     
  4. Nobber22

    Nobber22
    Well-known Member

    Joined:
    Jun 6, 2002
    Messages:
    2,982
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Berkshire
    Ratings:
    +111
  5. jimok78

    jimok78
    Standard Member

    Joined:
    Oct 2, 2006
    Messages:
    36
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +0
    I got in touch with Mission, had a prompt email back from them saying I could buy new drive units for about £58 and to phone through to order them. Result!
     

Share This Page

Loading...