No LCN since freeview reshuffle

ashyt16

Standard Member
I can't work out if this is the TV, the reshuffle or both causing the issue.
Since the reshuffle I was getting notifications on some channels to retune. I did and now all channels are in alphabetical order not LCN order with 4 music etc and the 5 channels coming first. Also seem to have multiple versions of the same channel, mostly BBC channels including the radio channels.

The TV is a fairly new Samsung TV. My area is Grange over sands. Other Tv's in the house, namely Older LG Tv's are fine.

I've tried absolutely everything. Retuned a million times using auto and manual, factory reset, tried changing country, (Samsung Tv's only allow to select 'other' for UK Tv's or I can select a European country).
Checked the aerial connection which is fine.

In the Service menu, the region is set to PANEURO and EU.

I'm at a loss as to why the TV is ignoring the LCN?
 

mikej

Well-known Member
There is often an option to list the channels in either LCN or alphabetical order - check the list/EPG view for any options you might have missed to change this. It could be a coloured button ? Also check the Freeview set-up menu for any display order or EPG view options.

Are your duplicate BBC channels in the 750+ LCN region ? If so, there were some changes to Freeview a few months ago (on my transmitter at least) which moved the main BBC channels to an alternative frequency and these channels were also given a temporary home in the 750+ region to allow people time to sort out any aerial issues. If that's the case for you, then it's likely an automatic retune would pick these additional channels up as well, if they're still being broadcast (the current covid situation has delayed some changes). If they're not at 750+, then presumably you're picking up unwanted signals from another transmitter.

The best option to resolve duplicate channel issues is to do a manual retune. First, do an automatic retune with the aerial unplugged to wipe the current channels (alternatively, you could do a factory reset but you'll obviously lose all your TV settings), then put your postcode and house number in the checker on the Freeview website, scroll to the bottom of the channel list and click on 'Detailed View'. Presuming that your aerial is pointed at the 'most likely transmitter', do a manual retune to each of the UHF frequencies ('N') in the top table.

Apologies if any of this is obvious - always good to start with the basics :)
 

Clem_Dye

Distinguished Member
First, try tuning with the aerial disconnected, to clear the existing cache. Then tune manually, adding one mux at a time, and check to see if the issue persists. If this diesn’t sort it then you’ll need to talk to Samsung.
 

Rodders53

Distinguished Member
In the Service menu, the region is set to PANEURO and EU.
That sound a possible issue.
Change that to be UK... or GB?
Probably best via a 'factory reset/first time install' and choosing UK/GB as the country at the start.

I'm at a loss as to why the TV is ignoring the LCN?
LCN is in the UK Freeview DVB-T/T2 spec. Generic EU is different?

AFAIK Samsung don't do UK/Ireland-only or European-only sets like Panasonic, so selecting the wrong country will probably mess stuff up?
If only other EU countries are offered with no UK/GB option a call to Samsung support may be in order.

G-o-S is able to receive England and Wales from Lancaster/Winter Hill and Moel-y-Parc. Hence the duplicates? . But a modern DVB-T2 set should allow choice of nation/region to store... if in the UK/GB setting.
 

ashyt16

Standard Member
Thanks for all the suggestions, but honesty I've tried them all. Manual tuning does allow me to filter out the extra duplicates, but still end up in the wrong LCN.
The TV only let's you sort channels by number or name. Name gives you alphabetical order. Number doesn't change anything because everything is numbered 1 to whatever in order of the alphabetical channels. So channel 1 is the first alphabetical channel and so forth.

Recent Samsung TVs don't seem to have a UK setting in either the service menu or the setup from what I can gather.
Setup asks for the postcode and sets up the freeview region from that, which is correctly showing Granada in the settings.
In any case this is how it was from when I first bought the TV and it was fine then.

Im starting to lean towards an issue with the tuner firmware not compatible since the reshuffle causing the issue.
Everything else is fine but this one issue.
At the end of the day as its a Samsung I can manually sort the channel list correctly, but it's just annoying.
 

Rodders53

Distinguished Member
Postcode input is usually only for freesat to get the correct region/nation. A new one on me for it to be used for Freeview, and it would require an internet connection to work, as well.

Samsung TV model number?
Is there a master thread on that model/range in AVForums? Set owners may not see this sub-forum?
 

ashyt16

Standard Member
Postcode input is usually only for freesat to get the correct region/nation. A new one on me for it to be used for Freeview, and it would require an internet connection to work, as well.

Samsung TV model number?
Is there a master thread on that model/range in AVForums? Set owners may not see this sub-forum?
If I don't input the postcode I can select the freeview region manually whereby it will let me select freeview London, freeview northwest(granada), Yorkshire and a few others.
This is definitely for freeview not satellite.

I have posted this in the Samsung TV section also to see if anyone else suffers the same issue.
Probably get less response in there as all they do is moan about PQ quality on their £1500 Tv's.

Tv is a UE49RU7300KXXU.
 

Similar threads

The latest video from AVForums

Podcast: Home AV, TV, Tech News & Reviews, Plus The Best of July 2020
Top Bottom