No channels found

beachlou

Standard Member
Can anyone please help?

We've moved into a new house a month ago, plugged the TV in (LG with inbuilt freeview) and got fine reception and all channels.

It started to slowly deteriote and has now gone completely. We've tried retuning in many times (as well as factory reset) and have just bought an indoor aerial to see if the outdoor aerial was a problem, but still nothing when we re-tune.

We're in Swansea and have not had problems before. COuld it be that the inbuilt freeview has gone? We don't have any other TVs we could try to see if it is this. It's been 2.5 wks now and I'm starting to really miss tv.

Thanks in advance.
 

kjhskj75

Novice Member
Looks like an aerial problem.

Either that or the cables connecting it with the TV. You need to get someone in to check.

Indoor set-top aerials rarely give good results, so that is not surprising.
 

beachlou

Standard Member
Ok, thanks for replying. Do you know how much it would be to get someone to have a look? We're renting so I'm hoping if it is the aerial our landlord will buy a new one.
 

Rodders53

Distinguished Member
Much of Swansea watches the Kilvey Hill transmitter and the aerial rods need to be vertically polarised as opposed to the more common horizontal (as would be used for Wenvoe).

It's worth talking to your Landlord if you've made all the usual aerial cable, plug and socket checks.

Ideally you need to try another TV (or set-top box) on the aerial (borrowed from a friend, neighbour or colleague, perhaps) in case it is a TV fault, but the Landlord may be able to assist with that check?
 

The latest video from AVForums

Podcast: Large Screen HDR TV or Projector For Home Cinema + Best of the Month
Support AVForums with Patreon

Top Bottom