Nightmare before Christmas 2003 Fiesta Zetec 1.4 idle/misfire

Sarah Thomas

Novice Member
Hi
I am having an absolute nightmare with my new 2003 1.4 Zetec Fiesta that I recently got conned in buying via Ebay a week ago.
Upon buying the vehicle there was no problem with the engine it ran like a dream - yes accelerator was tied down with a cable tie - what I have found out since taking to a garage!!! - This has now been taken off. Obviously another ploy to sell the car..
The issue is now the car doesn't run properly in low gears when coming to a junction it conks out..It intermittently conks out when it heats up? Revs of the engine misfire also.
The garage took the head gasket off and replaced two valves on the outlet exhaust as they were leaking. It looked like the head had been taken off previously? and valves were not lapped in properly and wrong sealant used for the rock cover when previously worked on (now panic is setting in).
The garage also replaced spark plugs, ignition coil, gasket and cleansed the catalytic converter. It has improved slightly but still conks out and takes a while sometimes for revs to come down when in higher gears? They consulted other garages in the area and none of them could understand why the car was missing revs?
The car judders on low gears/idle?
Please any help would be appreciated I have now spent £1200 buying it and another £800 trying to rectify this dodgey car sale..
Regards,
 

MC77

Well-known Member
Personally, I'd take it as a harsh lesson learnt and get rid of it sharpish. Sounds like one of 'those' cars. My mate had a Clio very similar to it, bought it for about 600 quid, spent nearly 1500 in the space of 3 months.
 

The latest video from AVForums

The Best Movies and TV Shows Coming to Netflix in November 2020: Tom's Thumbs.
Top Bottom