NEWS: NAD T 778 flagship AVR & Owner's Thread

CynanX

Active Member
Happened again this morning. T778 powers up then shuts itself down. Had to leave it off for 5 minutes with the switch at the back. The display now doesn’t show anything and had to go through the BluOS update again to fix that. Second unit is worse than the first. :(

Made my mind up. It’s going back and I won’t be getting another (it’s not wife family friendly and it should not have these problems for the money). I’ll stay with my older AVR using optical out from the TV until more units come out next year - currently looking at the Rotel RAP-1580
MkII but failing that... does not look like there is much option other than a Denon.

For all those considering this unit I’d now recommend you stay away. Would be interested to see a poll though on who has issues vs who’s not, as I cannot understand how some does not experience these issues.
 
I am guessing they mean ASR, which does some measurements, which may or may not make any difference to the sound we hear, and says that a mid-range Denon has better numbers for some of the measurements.
So he does measurements but doesn't listen. What is the point in that.
 

tin69

Active Member
Happened again this morning. T778 powers up then shuts itself down. Had to leave it off for 5 minutes with the switch at the back. The display now doesn’t show anything and had to go through the BluOS update again to fix that. Second unit is worse than the first. :(

Made my mind up. It’s going back and I won’t be getting another (it’s not wife family friendly and it should not have these problems for the money). I’ll stay with my older AVR using optical out from the TV until more units come out next year - currently looking at the Rotel RAP-1580
MkII but failing that... does not look like there is much option other than a Denon.

For all those considering this unit I’d now recommend you stay away. Would be interested to see a poll though on who has issues vs who’s not, as I cannot understand how some does not experience these issues.
Thanks for a balanced view unlike some cheerleader/fanboy opinions...
 
Last edited:
I had issues with my first couple but this one is rock solid. If I had any problems with it I would say so. ;)
 

Rambles

Distinguished Member
So he does measurements but doesn't listen. What is the point in that.
Because it is interesting to know how the device measures and is a good balance to the many subjective reviews already available about how it sounds (how it sounds in the reviewers room with their speakers, sources etc).
 

steviedr

Distinguished Member
Sorry to hear that @CynanX
You can’t say you haven’t tried - hope you have more luck on your next AVR choice.

I have a few niggles that I hope a replacement will sort out (ignoring initial pop as that seems to be a feature :)).
It is disappointing the software is a little buggy.

Can’t recall seeing too many fan boys on here.
Most of us have had issues and report them to Nad as well as on here. For most (who post here), generally it’s been positive on the sound experience and not positive on the various bugs.
 
Because it is interesting to know how the device measures and is a good balance to the many subjective reviews already available about how it sounds (how it sounds in the reviewers room with their speakers, sources etc).
Can't beat listening for your self in your own room.
 

XxSLYxx

Active Member
Happened again this morning. T778 powers up then shuts itself down. Had to leave it off for 5 minutes with the switch at the back. The display now doesn’t show anything and had to go through the BluOS update again to fix that. Second unit is worse than the first. :(

Made my mind up. It’s going back and I won’t be getting another (it’s not wife family friendly and it should not have these problems for the money). I’ll stay with my older AVR using optical out from the TV until more units come out next year - currently looking at the Rotel RAP-1580
MkII but failing that... does not look like there is much option other than a Denon.

For all those considering this unit I’d now recommend you stay away. Would be interested to see a poll though on who has issues vs who’s not, as I cannot understand how some does not experience these issues.
I take it your not considering the new yammy aventage line, think a few have said will be announced on the 21st?
 

steviedr

Distinguished Member
Maybe it’s my room setup or I had a rouge A3070, but the Nad from an immersive audio perspective kicked the Yamaha’s butt, especially on the bass side.

From a bug perspective, the Yamaha was very stable, but it hasn’t really changed in the last decade. It will be interesting to see if the new models are as stable (only assuming its going to be different due to new chassis, maybe OS will be the same).
 

XxSLYxx

Active Member
Maybe it’s my room setup or I had a rouge A3070, but the Nad from an immersive audio perspective kicked the Yamaha’s butt, especially on the bass side.

From a bug perspective, the Yamaha was very stable, but it hasn’t really changed in the last decade. It will be interesting to see if the new models are as stable (only assuming its going to be different due to new chassis, maybe OS will be the same).
Yeah I think I'm talking myself into more reliable options hoping that one of them will sound nice to me and then if I can get a decent sub with its own eq it might just do the job.
 

CynanX

Active Member
I really want to stay with Dirac. But I’m thinking I might try an Anthem as well. I know this is silly but I really don’t like the curved look of the new Yamaha’s.
 

XxSLYxx

Active Member
I really want to stay with Dirac. But I’m thinking I might try an Anthem as well. I know this is silly but I really don’t like the curved look of the new Yamaha’s.
Yeah can't say I like the look of the new Yamaha’s either, the old models looked fine. But apparently this model is "built new from the ground up"🙄. I'll wait for a second opinion on that one.
 
Thats good to know that there is one that’s working.. but what makes that one work and others not?
I don't know but what I can tell you is the one I have is one of the first batch.
 

Matyam

Active Member
I think clear as a bell is how I would describe mine even at 11,asr quote my nad 2200 at a much higher snr than the t778 but there is know contest ,it was clear before dirac but with its great.Waited longtime for a room correction which worked properly and at a reasonablish price ,the bigger the speakers better the rewards.
 

CynanX

Active Member
Good news everyone! Read this from NAD support...

"After speaking with our engineering team regarding your specific issue they have been able to replicate it here in our labs. Our engineering team will be looking into this further and be providing a fix for this issue in a future firmware update.

This is in regards to both the HDMI source switch POP noise as well as the LCD blank display you are noticing.

Unfortunately us here in technical support are not provided a timeline on future development and releases so I can not say for certain when this update will become available. However rest assured that our engineering team will be doing everything they can to resolve this issue as soon as possible."

Now unfortunately my unit still refuses to switch on for longer than a few seconds so it's effectively dead, but in light of this I will be giving a 3rd unit a try!

(don't suppose anyone knows how to do a reset without using the menu?)
 

steviedr

Distinguished Member
Phil mentioned on last nights pod he is getting on well with it and likes the sound, review will post soon.

Thats good news @CynanX Nad can replicate the issue, really weird your replacement is bricked. If you have tried everything else what about this (it’s for a different model, but I guess you have nothing to lose). I’m not at home, so don’t know if those buttons exist on the remote.
I take it you have had it turned off at the mains for at least 10 mins ?
 

GigaChunk

Member
Good news everyone! Read this from NAD support...

"After speaking with our engineering team regarding your specific issue they have been able to replicate it here in our labs. Our engineering team will be looking into this further and be providing a fix for this issue in a future firmware update.

This is in regards to both the HDMI source switch POP noise as well as the LCD blank display you are noticing.

Unfortunately us here in technical support are not provided a timeline on future development and releases so I can not say for certain when this update will become available. However rest assured that our engineering team will be doing everything they can to resolve this issue as soon as possible."

Now unfortunately my unit still refuses to switch on for longer than a few seconds so it's effectively dead, but in light of this I will be giving a 3rd unit a try!

(don't suppose anyone knows how to do a reset without using the menu?)
I wouldn't hold your breath for a fix. I got an identical reply back in May regarding the Rhye distortion issue, and they still haven't fixed it:

"After speaking with our engineering team regarding the PCM distortion 'Small' Speaker Configuration issue, they have been able to replicate it. Our engineering team will be looking into this further and be providing a fix for this issue in a future firmware update.

Unfortunately, we here in technical support are not provided a timeline on future development and releases so I can not say for certain when this update will become available. However, rest assured that our engineering team will be doing everything they can to resolve this issue as soon as possible.

I'm sorry I do not have a more immediate solution for you but in the meantime, if you have any further questions for me, please feel free to let me know."


I chased them again in June, and got this reply:

"Thank you for following up regarding your T 778 distortion issue!

I have a T 758v3 here at home so I tried testing this issue against the most recent beta firmware. My tests showed that the issue has been resolved!

As we are not permitted to provide beta firmware, I must assume that the person providing this info is either a registered Beta tester or another member of our support team.

Please keep an eye out for the next firmware release as it should include this fix for the distortion noticed when your Fronts are set to SMALL"

The most recent DSP firmware they released hasn't fixed the issue. Don't know what they're playing at, there are so many bugs with this thing. The only thing they seem to have fixed since the 778 was released is the disappearing Dirac slots (in my experience anyway).

The pops are still driving me nuts, and my screen/BluOS also suffers from occasional blanks which require two reboots to bring back to life.
 
Last edited:
I wouldn't hold your breath for a fix. I got an identical reply back in May regarding the Rhye distortion issue, and they still haven't fixed it:

"After speaking with our engineering team regarding the PCM distortion 'Small' Speaker Configuration issue, they have been able to replicate it. Our engineering team will be looking into this further and be providing a fix for this issue in a future firmware update.

Unfortunately, we here in technical support are not provided a timeline on future development and releases so I can not say for certain when this update will become available. However, rest assured that our engineering team will be doing everything they can to resolve this issue as soon as possible.

I'm sorry I do not have a more immediate solution for you but in the meantime, if you have any further questions for me, please feel free to let me know."


I chased them again in June, and got this reply:

"Thank you for following up regarding your T 778 distortion issue!

I have a T 758v3 here at home so I tried testing this issue against the most recent beta firmware. My tests showed that the issue has been resolved!

As we are not permitted to provide beta firmware, I must assume that the person providing this info is either a registered Beta tester or another member of our support team.

Please keep an eye out for the next firmware release as it should include this fix for the distortion noticed when your Fronts are set to SMALL"

The most recent DSP firmware they released hasn't fixed the issue. Don't know what they're playing at, there are so many bugs with this thing. The only thing they seem to have fixed since the 778 was released is the disappearing Dirac slots (in my experience anyway).

The pops are still driving me nuts, and my screen/BluOS also suffers from occasional blanks which require two reboots to bring back to life.
I've already tested this on mine and it is fine. Don't understand how you have the problem and others don't
 

GigaChunk

Member
I've already tested this on mine and it is fine. Don't understand how you have the problem and others don't
1. Ensure your front speakers are set to "small". Dirac on vs. off makes no difference.
2. Through BluOS, stream this song. If you don't have Spotify, the same version can be found on Tidal.
3. The issue is heard near the end, at 2:50. Here is what you are listening for. This can be A/B'd by switching front speaker configurations between large and small, and replaying that section of the song.
 
1. Ensure your front speakers are set to "small". Dirac on vs. off makes no difference.
2. Through BluOS, stream this song. If you don't have Spotify, the same version can be found on Tidal.
3. The issue is heard near the end, at 2:50. Here is what you are listening for. This can be A/B'd by switching front speaker configurations between large and small, and replaying that section of the song.
As I have said I have tried it and cannot hear the distortion. I tried it with tidal and Spotify.
 

Matyam

Active Member
Must be a deluded fanboy,:clap:
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month

Latest News

Sean Connery: James Bond icon dies aged 90
  • By Andy Bassett
  • Published
Anthem launches latest AV receivers, processors and amplifiers
  • By Andy Bassett
  • Published
Naim and Focal discount premium music systems
  • By Andy Bassett
  • Published
What's new on Sky and NOW TV UK for November 2020
  • By Andy Bassett
  • Published
AVForums Podcast: 28th October 2020
  • By Phil Hinton
  • Published
Top Bottom